Hypervisor Connection Issues

Version 1
    This document was generated from CDN thread

    Created by: Geoff Yates on 20-11-2010 01:34:01 AM
    Hi All,
     
    Running into Hypervisor Connection issues.
     
    Router Config
     
    interface GigabitEthernet0/0
     ip address 10.66.236.41 255.255.255.192
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/2
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface SM1/0
     ip address 192.168.10.100 255.255.255.0
     service-module ip address 192.168.10.1 255.255.255.0
     !Application: SRE-V Running on SMV
     service-module ip default-gateway 192.168.10.100
     service-module mgf ip address 192.168.20.1 255.255.255.0
     service-module mgf ip default-gateway 192.168.20.100
     hold-queue 60 out
    !
    interface SM1/1
     description Internal switch interface connected to Service Module
     switchport mode trunk
    !
    interface Vlan1
     ip address 192.168.20.100 255.255.255.0
    !
    !
    router eigrp 1
     network 10.66.236.0 0.0.0.255
     network 192.168.0.0 0.0.255.255
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    ip route 0.0.0.0 0.0.0.0 10.66.236.1
    ip route 192.168.20.1 255.255.255.255 Vlan1
     
    SRE Output
     
    se-192-168-10-1# show hypervisor nic
    Name    PCI           Driver      Link Speed     Duplex MAC Address       MTU
    vmnic1  0000:01:00.00 e1000e      Down 0Mbps     Half   00:23:eb:a1:08:d2 1500
    vmnic2  0000:02:00.00 bnx2        Up   1000Mbps  Full   88:43:e1:0a:94:81 1500
    vmnic3  0000:02:00.01 bnx2        Up   1000Mbps  Full   88:43:e1:0a:94:80 1500
     
    Noticed vmnic1 is down. Is it meant to be down?
     
    se-192-168-10-1# show hypervisor ip
    Hostname:               localhost
    Domain Name:            None
    IP Config:              192.168.20.1(Subnet Mask: 255.255.255.0)
                            169.254.1.1(Subnet Mask: 255.255.255.0)
    Default Gateway:        192.168.20.100
    Preferred DNS Server:   None
    Alternative DNS Server: None

    The router is directly connected to a Cat 6500 whose IP is 10.66.236.1
     
    From the SRE itself I can ping the Cat 6500's address
     
    se-192-168-10-1# ping 10.66.236.1
    PING 10.66.236.1 (10.66.236.1) 56(84) bytes of data.
    64 bytes from 10.66.236.1: icmp_seq=1 ttl=254 time=2.55 ms
    64 bytes from 10.66.236.1: icmp_seq=2 ttl=254 time=0.785 ms
    64 bytes from 10.66.236.1: icmp_seq=3 ttl=254 time=0.411 ms
    64 bytes from 10.66.236.1: icmp_seq=4 ttl=254 time=0.402 ms
    64 bytes from 10.66.236.1: icmp_seq=5 ttl=254 time=0.404 ms

    --- 10.66.236.1 ping statistics ---
    5 packets transmitted, 5 received, 0% packet loss, time 9ms
    rtt min/avg/max/mdev = 0.402/0.911/2.554/0.834 ms, ipg/ewma 2.252/1.696 ms
     
    But not vice versa.
     
    BNE-6500#ping 192.168.20.1       

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
    .....
    Success rate is 0 percent (0/5)
     
    The 6500 can ping VLAN 1 (default gateay for mgf) on the router:
     
    BNE-6500#ping 192.168.20.100

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.20.100, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
     
    The 6500 has a route for 192.168.20.1 (mgf IP interface)
     
         192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
    D       192.168.20.0/24 [90/28416] via 10.66.236.41, 00:28:03, Vlan1
    S       192.168.20.1/32 [1/0] via 10.66.236.41
     
    note: I changed to static and over ridden the EIGRP advertised route
     
    If I run debug ip icmp on the router it shows no icmp echo reply sent if I ping 192.168.20.1. Will if I hit 192.168.20.100.
     
    I don't understand what vmnic1's role is so that may be the issue.
     
    Even tried your suggestions for the other guys by manually adding a default gateway for hypervisor
     
    hypervisor set ip default-gateway 192.168.20.100
     
    Reloaded the hypervisor a couple of times just in case.
     
    Cheers,
     
    Geoff
     

    Subject: RE: New Message from Geoff Yates in Service Ready Engine Virtualization - S
    Replied by: Radhika Miriyala on 20-11-2010 01:34:01 AM
    Geoff,

    Vimnic 1 is the external (front facing ) NIC on the SRE. So unless you connected that it will show up as down. The hypervisor uses VMNIC3 (in your case).



    Did you activate the license on the module. Can you please give the output of ¿show license¿

    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, September 28, 2010 9:59 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Geoff Yates in Service Ready Engine Virtualization - SRE-V Beta Testing: Hypervisor Connection Issues



    Geoff Yates has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    Hi All,

    Running into Hypervisor Connection issues.

    Router Config

    interface GigabitEthernet0/0
    ip address 10.66.236.41 255.255.255.192
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/2
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface SM1/0
    ip address 192.168.10.100 255.255.255.0
    service-module ip address 192.168.10.1 255.255.255.0
    !Application: SRE-V Running on SMV
    service-module ip default-gateway 192.168.10.100
    service-module mgf ip address 192.168.20.1 255.255.255.0
    service-module mgf ip default-gateway 192.168.20.100
    hold-queue 60 out
    !
    interface SM1/1
    description Internal switch interface connected to Service Module
    switchport mode trunk
    !
    interface Vlan1
    ip address 192.168.20.100 255.255.255.0
    !
    !
    router eigrp 1
    network 10.66.236.0 0.0.0.255
    network 192.168.0.0 0.0.255.255
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    ip route 0.0.0.0 0.0.0.0 10.66.236.1
    ip route 192.168.20.1 255.255.255.255 Vlan1

    SRE Output

    se-192-168-10-1# show hypervisor nic
    Name    PCI           Driver      Link Speed     Duplex MAC Address       MTU
    vmnic1  0000:01:00.00 e1000e      Down 0Mbps     Half   00:23:eb:a1:08:d2 1500
    vmnic2  0000:02:00.00 bnx2        Up   1000Mbps  Full   88:43:e1:0a:94:81 1500
    vmnic3  0000:02:00.01 bnx2        Up   1000Mbps  Full   88:43:e1:0a:94:80 1500

    Noticed vmnic1 is down. Is it meant to be down?

    se-192-168-10-1# show hypervisor ip
    Hostname:               localhost
    Domain Name:            None
    IP Config:              192.168.20.1(Subnet Mask: 255.255.255.0)
                            169.254.1.1(Subnet Mask: 255.255.255.0)
    Default Gateway:        192.168.20.100
    Preferred DNS Server:   None
    Alternative DNS Server: None

    The router is directly connected to a Cat 6500 whose IP is 10.66.236.1

    From the SRE itself I can ping the Cat 6500's address

    se-192-168-10-1# ping 10.66.236.1
    PING 10.66.236.1 (10.66.236.1) 56(84) bytes of data.
    64 bytes from 10.66.236.1: icmp_seq=1 ttl=254 time=2.55 ms
    64 bytes from 10.66.236.1: icmp_seq=2 ttl=254 time=0.785 ms
    64 bytes from 10.66.236.1: icmp_seq=3 ttl=254 time=0.411 ms
    64 bytes from 10.66.236.1: icmp_seq=4 ttl=254 time=0.402 ms
    64 bytes from 10.66.236.1: icmp_seq=5 ttl=254 time=0.404 ms

    --- 10.66.236.1 ping statistics ---
    5 packets transmitted, 5 received, 0% packet loss, time 9ms
    rtt min/avg/max/mdev = 0.402/0.911/2.554/0.834 ms, ipg/ewma 2.252/1.696 ms

    But not vice versa.

    BNE-6500#ping 192.168.20.1       

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
    .....
    Success rate is 0 percent (0/5)

    The 6500 can ping VLAN 1 (default gateay for mgf) on the router:

    BNE-6500#ping 192.168.20.100

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.20.100, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

    The 6500 has a route for 192.168.20.1 (mgf IP interface)

         192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
    D       192.168.20.0/24 [90/28416] via 10.66.236.41, 00:28:03, Vlan1
    S       192.168.20.1/32 [1/0] via 10.66.236.41

    note: I changed to static and over ridden the EIGRP advertised route

    If I run debug ip icmp on the router it shows no icmp echo reply sent if I ping 192.168.20.1. Will if I hit 192.168.20.100.

    I don't understand what vmnic1's role is so that may be the issue.

    Even tried your suggestions for the other guys by manually adding a default gateway for hypervisor

    hypervisor set ip default-gateway 192.168.20.100

    Reloaded the hypervisor a couple of times just in case.

    Cheers,

    Geoff



    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2584247>
    or simply reply to this email.

    Subject: RE: New Message from Geoff Yates in Service Ready Engine Virtualization - S
    Replied by: Geoff Yates on 20-11-2010 01:34:01 AM
    se-192-168-10-1# show license
    Index 0 Feature: SRE-V-HOST-LIC
        Period left:  8 weeks  4 days
        License Type: Evaluation
        License State: Active, Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
    Index 1 Feature: SRE-V-RMA-LIC 
        Period left:  0 minute   0 second
     
     

    Subject: RE: New Message from Geoff Yates in Service Ready Engine Virtualization - S
    Replied by: Radhika Miriyala on 20-11-2010 01:34:01 AM
    Geoff,

    If you look at the output below you see that the eula has not been accepted. So Eval license is present but not in use.

    Can you issue the cli ¿license activate sreVHost¿ on the SRE.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, September 28, 2010 10:22 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Geoff Yates in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from Geoff Yates in Service Ready Engine Virtualization - S



    Geoff Yates has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    se-192-168-10-1# show license
    Index 0 Feature: SRE-V-HOST-LIC
        Period left:  8 weeks  4 days
        License Type: Evaluation
        License State: Active, Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
    Index 1 Feature: SRE-V-RMA-LIC 
        Period left:  0 minute   0 second


    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2584287>
    or simply reply to this email.

    Subject: RE: New Message from Geoff Yates in Service Ready Engine Virtualization - S
    Replied by: Anurag Gurtu on 20-11-2010 01:34:02 AM
    You need to activate the license. Please issue



    license activate srevhost

    Subject: RE: New Message from Geoff Yates in Service Ready Engine Virtualization - S
    Replied by: Geoff Yates on 20-11-2010 01:34:02 AM
     
    Thanks guys! Missed that page its on 5-6 of the manual.
     
    Have a Vcentre issue now its whinging about permissions when trying to connect.
     
    I used username esx-admin and password change_it and i get the following:
     
    Failed to configure the VIM account on the host.
     
    Cheers,
     
    Geoff

    Subject: RE: New Message from Geoff Yates in Service Ready Engine Virtualization - S
    Replied by: Radhika Miriyala on 20-11-2010 01:34:02 AM
    Geoff,

    Vcenter support is not present with this release. You can use a Vsphere client to connect to the hypervisor.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, September 28, 2010 11:01 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Geoff Yates in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from Geoff Yates in Service Ready Engine Virtualization - S



    Geoff Yates has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------

    Thanks guys! Missed that page its on 5-6 of the manual.

    Have a Vcentre issue now its whinging about permissions when trying to connect.

    I used username esx-admin and password change_it and i get the following:

    Failed to configure the VIM account on the host.

    Cheers,

    Geoff
    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2586313>
    or simply reply to this email.

    Subject: RE: New Message from Geoff Yates in Service Ready Engine Virtualization - S
    Replied by: Geoff Yates on 20-11-2010 01:34:02 AM
    Geoff,

    Vcenter support is not present with this release. You can use a Vsphere client to connect to the hypervisor.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, September 28, 2010 11:01 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Geoff Yates in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from Geoff Yates in Service Ready Engine Virtualization - S



    Geoff Yates has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------

    Thanks guys! Missed that page its on 5-6 of the manual.

    Have a Vcentre issue now its whinging about permissions when trying to connect.

    I used username esx-admin and password change_it and i get the following:

    Failed to configure the VIM account on the host.

    Cheers,

    Geoff
    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2586313>
    or simply reply to this email.

     
    That it explains it.
     
    This seems like a limitation is this going to be added before final release?
     
    Cheers,
     
    Geoff