Issue with sm 1/0 interface connectivity

Version 1
    This document was generated from CDN thread

    Created by: Steve Matthews on 20-11-2010 01:33:36 AM
    Hi Brett

    Having issues getting my SRE-V interface¿s to work  at all   details and logs and config below...couple different issues over time.



     The unit is accessible on 10.53.1.250  cisco/cisco. SRE-V on sm1/0 if someone wants to take a look and do whatever they think is necc. The license is enabled.

    Tried several variations ¿ but currently cannot get back to the ¿169.154¿ address scenario.. (in this scenario the management VM was reachable and did boot ¿ just MGF was not accessible) - I have completely uninistalled V couple times now.. Was thinking to go back to AXP 1.5.3 ;) to see if it makes a difference.



    Cheers

    Steve



    ==========================================

    Maybe this is an issue - it appears to be  different to CSCti11106..



    My 900 already had AXP 1.5.3 installed and working.



    I first upgraded IOS - and rebooted (AXP up)



    Going into SM 1/0 gave me the existing ip address..



    I tried to add mgf addresses however IOS did not accept the CLI.? (is this because AXP was active even though new IOS) so I continued without. (note SM1/1 was shut.. should this prevent mgf address being added? as per CSCti11106)





    I installed the pkg's using ftp. and followed and recorded the session output for the install.



    In session I noted that the vmk interface (eth2)  was taking a 169.154.1.x address as MGF was not actively configured on IOS.



    I then added MGF interface addresses to IOS (a 14.0.0.x address) as after module had installed V it seemed to recognise the need to allow MGF addresses.



    IOS did not show the route in the routing table - the SRE-V still shows 169.154.1.x.



    ======================================

    I hard reset SRE-V thinking it might acquire mgf ip.. it did not.



    I reset the complete G2 this made no difference. - including a power cycle.



    I resorted to uninstalling the V software again - IOS contained the mgf addresses and SM 1/1 was open.



    Re-installed ¿ still same.

    Changed the mgf addresses to be active on a vlan (10) put both MGF addresses on this vlan. Repowered card, unit calls out constantly ¿ asking to acquire address.

    . Thinks the address is not working..



    Populating resource values from /usr/etc/products/galactica/smv_rsrc_file

    Bring up hgNet interface eth2.

    Validating hgNet connection...link is ready.

    Processing manifests . . . . . . . . . . . complete

    ==> Management interface is eth0

    ==> Management interface is eth0

    Waiting for IOS to register IP address.

     - waited 10 seconds...

    Waiting for IOS to register IP address.

     - waited 20 seconds...

    Waiting for IOS to register IP address.

     - waited 30 seconds...

    Waiting for IOS to register IP address.

     - waited 40 seconds...

    Waiting for IOS to register IP address.

     - waited 50 seconds...

    Waiting for IOS to register IP address.

     - waited 60 seconds...

    Waiting for IOS to register IP address.

     - waited 70 seconds...

    Waiting for IOS to register IP address.

     - waited 80 seconds...

    Waiting for IOS to register IP address.

     - waited 90 seconds...

    Waiting for IOS to register IP address.

     - waited 100 seconds...

    Waiting for IOS to register IP address.

     - waited 110 seconds...

    Waiting for IOS to register IP address.

     - waited 120 seconds...

    Waiting for IOS to register IP address.

     - waited 130 seconds...

    Waiting for IOS to register IP address.

     - waited 140 seconds...

    Waiting for IOS to register IP address.

     - waited 150 seconds...

    Waiting for IOS to register IP address.

     - waited 160 seconds...

    Waiting for IOS to register IP address.

     - waited 170 seconds...

    Waiting for IOS to register IP address.

     - waited 180 seconds...

    Waiting for IOS to register IP address.

     - waited 190 seconds...

    WARNING:: IOS communication appears delayed!

    WARNING::

    WARNING:: Please verify the Service Engine IP Address

    WARNING:: and Default Gateway are configured correctly

    WARNING:: on the service engine interface in IOS.

    Waiting for IOS to register IP address.

     - waited 200 seconds...

    WARNING:: IOS communication appears delayed!





    Config is:

    2921-sre-testbed#sh run

    Building configuration...



    Current configuration : 2745 bytes

    !

    ! Last configuration change at 12:27:28 UTC Fri Aug 27 2010

    !

    version 15.1

    service timestamps debug datetime msec

    service timestamps log datetime msec

    no service password-encryption

    !

    hostname 2921-sre-testbed

    !

    boot-start-marker

    boot system flash:c2900sreios.bin

    boot-end-marker

    !

    !

    enable secret 5 $1$139I$AAWvjLqSyHDqeuJmKHGaS0

    !

    no aaa new-model

    !

    no ipv6 cef

    ip source-route

    ip cef

    !

    !

    !

    !

    !

    multilink bundle-name authenticated

    !

    !

    crypto pki token default removal timeout 0

    !

    !

    license udi pid CISCO2921/K9 sn FHK1430F1LE

    hw-module ism 0

    !

    hw-module sm 1

    !

    !

    !

    !

    !

    ip tftp source-interface GigabitEthernet0/1.100

    !

    !

    !

    !

    interface GigabitEthernet0/0

     no ip address

     shutdown

     duplex auto

     speed auto

    !

    interface ISM0/0

     ip address 11.0.0.1 255.255.255.0

     service-module ip address 11.0.0.2 255.255.255.0

     !Application: Online on SME

     service-module ip default-gateway 11.0.0.1

    !

    interface GigabitEthernet0/1

     no ip address

     media-type sfp

    !

    interface GigabitEthernet0/1.10

     encapsulation dot1Q 1 native

     ip address 10.53.1.250 255.255.255.128

    !

    interface GigabitEthernet0/1.100

     encapsulation dot1Q 100

     ip address 100.0.0.6 255.255.255.0

    !

    interface GigabitEthernet0/1.200

     encapsulation dot1Q 200

     ip address 200.0.0.6 255.255.255.0

    !

    interface GigabitEthernet0/2

     no ip address

     shutdown

     duplex auto

     speed auto

    !

    interface ISM0/1

     description Internal switch interface connected to Internal Service Module

     shutdown

    !

    interface SM1/0

     ip address 12.0.0.1 255.255.255.0

     service-module ip address 12.0.0.2 255.255.255.0

     !Application: SRE-V Running on SMV

     service-module mgf ip address 14.0.0.1 255.255.255.0 vlan 10

     service-module mgf ip default-gateway 14.0.0.2 vlan 10

    !

    interface SM1/1

     description Internal switch interface connected to Service Module

     switchport mode trunk

    !

    interface Vlan1

     no ip address

    !

    interface Vlan10

     ip address 14.0.0.14 255.255.255.0

    !

    ip forward-protocol nd

    !         

    no ip http server

    no ip http secure-server

    !

    ip route 10.53.0.0 255.255.0.0 10.53.1.129

    ip route 10.55.0.0 255.255.0.0 10.53.1.129

    ip route 64.0.0.0 255.0.0.0 10.53.1.129

    !

    !

    !

    tftp-server flash:/FOC14203TUG_20100816130447499.lic

    tftp-server flash:/FOC14262JW8_20100816130526856.lic

    !

    control-plane

    !

    !

    !

    line con 0

    line aux 0

    line 67

     no activation-character

     no exec

     transport preferred none

     transport input all

     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

     stopbits 1

     flowcontrol software

    line 131

     no activation-character

     no exec

     transport preferred none

     transport input all

     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

     stopbits 1

     flowcontrol software

    line vty 0 4

     password cisco

     login

     transport input all

    !

    exception data-corruption buffer truncate

    scheduler allocate 20000 1000

    end



    2921-sre-testbed#       

    =============================



    Lastest boot sequence..

    INIT: Sending p to run

    Rebooting ...



    shutdown: sending all processes the TERM signal...

    platform.config:    INFO platform.config server output END



    rbcp:    INFO rbcp daemon output END



    trace:    INFO trace daemon output END



    shutdown: sending all processes the KILL signal.

    shutdown: turning off swap

    shutdown: unmounting all file systems

    Please stand by while rebooting the system.

    Restarting system.



      Booting 'Cisco Management VM'



    root (hd0,0)

     Filesystem type is reiserfs, partition type 0x83

    kernel /bzImage root=/dev/sda1 ro plat=smv console=ttyS0,115200 quiet

       [Linux-bzImage, setup=0x1400, size=0x180598]

    initrd /initrd

       [Linux-initrd @ 0xb390000, 0xcf527 bytes]



    Platform: smv

    Using existing trace log

    Red Hat nash version 4.1.18 starting

    Mount /proc

    sd 0:0:0:0:  Assuming drive cache: write through

    sd 0:0:0:0:  Assuming drive cache: write through

    mknod --mode=600 /sysroot/dev/vmci c 254 0 - -1

    mknod --mode=666 /sysroot/dev/vsock c 10 63 - -1

    Verifying application level programs

    Debug version of cisco_init, no reboot upon verification failure!

    Application level programs verification OK!

    INIT: version 2.86 booting

    mounting proc fs ...

    mounting sys fs ...

    mounting /dev/shm tmpfs ...

    reiser root fs ...

    Remounting the root filesystem read-only...

    Reiserfs super block in block 16 on 0x801 of format 3.6 with standard journal

    Blocks (total/free): 124480/90743 by 4096 bytes

    Filesystem is clean

    Filesystem seems mounted read-only. Skipping journal replay.

    Checking internal tree..finished



    FILESYSTEM CLEAN

    Remounting the root filesystem read-write...



    kernel.sem = 1900 4000 32 100

    vm.overcommit_memory = 1





            Welcome to Cisco Service Engine



    Setting the system time from hardware clock



    ********** rc.aesop ****************

    Populating resource values from /etc/smv_rsrc_file

    Populating resource values from /etc/default_rsrc_file

    Populating resource values from /usr/etc/products/galactica/default_rsrc_file

    Populating resource values from /usr/etc/products/galactica/smv_rsrc_file

    Bring up hgNet interface eth2.

    Validating hgNet connection...link is ready.

    Processing manifests . . . . . . . . . . . complete

    ==> Management interface is eth0

    ==> Management interface is eth0

    Waiting for IOS to register IP address.

     - waited 10 seconds...

    Waiting for IOS to register IP address.

     - waited 20 seconds...

    Waiting for IOS to register IP address.

     - waited 30 seconds...

    Waiting for IOS to register IP address.

     - waited 40 seconds...

    Waiting for IOS to register IP address.

     - waited 50 seconds...

    Waiting for IOS to register IP address.

     - waited 60 seconds...

    Waiting for IOS to register IP address.

     - waited 70 seconds...

    Waiting for IOS to register IP address.

     - waited 80 seconds...

    Waiting for IOS to register IP address.

     - waited 90 seconds...

    Waiting for IOS to register IP address.

     - waited 100 seconds...

    Waiting for IOS to register IP address.

     - waited 110 seconds...

    Waiting for IOS to register IP address.

     - waited 120 seconds...














    <!--EndFragment-->

    Subject: RE: New Message from Steve Matthews in Service Ready Engine Virtualization
    Replied by: Ashwin Venkatesan on 20-11-2010 01:33:36 AM
    Hi Steve,

    I am having trouble connecting to 10.53.1.250. Is this up and running ?

    Thanks,
    Ashwin.

    Subject: RE: Issue with sm 1/0 interface connectivity
    Replied by: Anurag Gurtu on 20-11-2010 01:33:37 AM
    Remove vlan10 from mfg ip and gateway and configure vlan1 ip address
     

     service-module mgf ip address 14.0.0.1 255.255.255.0 vlan 10

     service-module mgf ip default-gateway 14.0.0.2 vlan 10

    !

    interface SM1/1

     description Internal switch interface connected to Service Module

     switchport mode trunk

    !

    interface Vlan1

     no ip address

    Subject: RE: New Message from Steve Matthews in Service Ready Engine Virtualization
    Replied by: Steve Matthews on 20-11-2010 01:33:37 AM
    Hi Ashwin.
    Its a UK lab and its reachable from Cisco corp -so you may have to add routing from a 171 net.
    As Anurag has pointed out - I will try vlan 1 - however i also tried with no vlan configured at all.
    Is it correct we are limited to vlan 1 if we use management vlans?
     
    kind regards
    Steve
     

    Subject: RE: New Message from Steve Matthews in Service Ready Engine Virtualization
    Replied by: Anurag Gurtu on 20-11-2010 01:33:37 AM
    Not sure if we are restricted but I would try with VLAN1 and see if that works.

    Thanks,

    Anurag Gurtu, CISSP

    Subject: RE: Issue with sm 1/0 interface connectivity -RESOLVED
    Replied by: Steve Matthews on 20-11-2010 01:33:39 AM
    Folks
    Resolved this issue - mostly my finger trouble.
    I would add that I think the config guide has some variations in how it shows the mgf IP and gateway addresses.
    The user docs might be cleaned up a bit to give a couple of specific examples one usin vlan 1 and another using another vlan and showing how this ties to the complete config/routing.

    Subject: RE: Issue with sm 1/0 interface connectivity -RESOLVED
    Replied by: chad patterson on 19-09-2013 01:30:01 PM
    Steve Matthews:
    Folks
    Resolved this issue - mostly my finger trouble.
    I would add that I think the config guide has some variations in how it shows the mgf IP and gateway addresses.
    The user docs might be cleaned up a bit to give a couple of specific examples one usin vlan 1 and another using another vlan and showing how this ties to the complete config/routing.
    So please detail for us the resolution.