SRE is not accessible after IOS upgrade

Version 1
    This document was generated from CDN thread

    Created by: Mohamed Rafi Meetheen on 20-11-2010 01:33:43 AM
    Hi,
     
    I have 2911 + SRE900 
     
    I have upgrade the 2911 IOS from c2900-universalk9-mz.SPA.150-1.M.bin to c2900-universalk9-mz.SSA.T_BASE_1_20100819.
     
    Since then I could not access the SRE. I have attached here with the configuration.
     

    2911-1#sh run
    Building configuration...
     
    Current configuration : 3836 bytes
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 2911-1
    !
    boot-start-marker
    boot system flash0:/c2900-universalk9-mz.SSA.T_BASE_1_20100819
    boot-end-marker
    !
    !
    logging buffered 51200 warnings
    !
    no aaa new-model
    !
    no ipv6 cef
    ip source-route
    no ip routing
    no ip cef
    !         
    !
    !
    !
    !
    ip domain name yourdomain.com
    multilink bundle-name authenticated
    !
    !
    crypto pki token default removal timeout 0
    !
    crypto pki trustpoint TP-self-signed-2379707370
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-2379707370
     revocation-check none
     rsakeypair TP-self-signed-2379707370
    !
    !
    crypto pki certificate chain TP-self-signed-2379707370
     certificate self-signed 01
      3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030 
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
      69666963 6174652D 32333739 37303733 3730301E 170D3130 30363134 32303330 
      33385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 33373937 
      30373337 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
      8100930D 57D266A5 C247706B D44402F8 45E7A6E4 3D171D98 6EE86847 0C077063 
      D9EFBFDA 84804FF9 54C5C461 32F007CB C554C877 8F563EAA DB48A1AE 18BDE116 
      44F0DEEE 0B15FFB3 9D607371 E2373E99 FE88C5A3 0702BF34 3DE83C7B 3E3D8804 
      4411F062 1C8A6132 AA5D056D 0B2ED2E0 7ABEF1A7 1A466A53 E8AEC60F BB53D16F 
      CB030203 010001A3 75307330 0F060355 1D130101 FF040530 030101FF 30200603 
      551D1104 19301782 15323931 312D312E 796F7572 646F6D61 696E2E63 6F6D301F 
      0603551D 23041830 16801460 DB3DD8FD CFA76731 AAD62657 AD814E01 21BF9D30 
      1D060355 1D0E0416 041460DB 3DD8FDCF A76731AA D62657AD 814E0121 BF9D300D 
      06092A86 4886F70D 01010405 00038181 00435E59 F99ACE19 9504010F 9ADBEEBD 
      4F9609A7 7531757A AEF4BD58 1D144933 1A279B98 48E1657D 13B1C616 E004C1A1 
      38596AC8 F66148BB CE7F4370 0EE5BE81 BE70673D 02BF1733 C2377EB0 85D8D7C6 
      5DFFAF11 71FD9836 275D0493 13E8BCC9 94EE9AD7 04D25B5C 083405EC 55642702 
      5861D546 C4C37786 FEDD9864 819A7C25 DC
       quit
    license udi pid CISCO2911/K9 sn FTX1347A1TA
    hw-module sm 1
    !
    !
    !
    username administrator privilege 15 secret 5 $1$26sn$lEEiTgoyhjsa9xLi/Gucn1
    !         
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
     description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
     ip address 10.89.100.195 255.255.255.192
     no ip route-cache
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/1
     no ip address
     no ip route-cache
     shutdown
     duplex auto
     speed auto
    !
    interface GigabitEthernet0/2
     no ip address
     no ip route-cache
     shutdown 
     duplex auto
     speed auto
    !
    interface SM1/0
     ip address 10.0.0.1 255.255.255.0
     no ip route-cache
     service-module fail-open
     service-module ip address 10.0.0.2 255.255.255.0
     service-module ip default-gateway 10.0.0.1
     hold-queue 60 out
    !
    interface SM1/1
     description Internal switch interface connected to Service Module
     shutdown
    !
    interface Vlan1
     no ip address
     no ip route-cache
    !
    ip default-gateway 10.89.100.193
    ip forward-protocol nd
    !
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    !
    access-list 23 permit 10.10.10.0 0.0.0.7
    !
    !
    !
    control-plane
    !
    !
    !
    line con 0
     login local
    line aux 0
    line 67
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line vty 0 4
     privilege level 15
     password solutions
     login
     transport input telnet
    line vty 5
     privilege level 15
     login local
     transport input telnet ssh
    line vty 6 15
     access-class 23 in
     privilege level 15
     login local
     transport input telnet ssh
    !
    exception data-corruption buffer truncate
    scheduler allocate 20000 1000
    end
     
    2911-1# 

    2911-1#sh ver
    Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Experimental Version 15.1(20100818:162633) [ssamant-t_base_1_0818 134]
    Copyright (c) 1986-2010 by Cisco Systems, Inc.
    Compiled Thu 19-Aug-10 00:49 by ssamant


    ROM: System Bootstrap, Version 15.0(1r)M1, RELEASE SOFTWARE (fc1)


    2911-1 uptime is 20 minutes
    System returned to ROM by reload at 14:25:01 UTC Tue Sep 14 2010
    System image file is "flash0:/c2900-universalk9-mz.SSA.T_BASE_1_20100819"
    Last reload type: Normal Reload
    Last reload reason: Reload Command






    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.
              
    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html


    If you require further assistance please contact us by sending email to
    export@cisco.com.


    Cisco CISCO2911/K9 (revision 1.0) with 479232K/45056K bytes of memory.
    Processor board ID FTX1347A1TA
    4 Gigabit Ethernet interfaces
    1 terminal line
    1 Services Module (SM) with Services Ready Engine (SRE)
    DRAM configuration is 64 bits wide with parity enabled.
    255K bytes of non-volatile configuration memory.
    254464K bytes of ATA System CompactFlash 0 (Read/Write)




    License Info:


    License UDI:


    -------------------------------------------------
    Device#   PID   SN
    -------------------------------------------------
    *0     CISCO2911/K9          FTX1347A1TA     






    Technology Package License Information for Module:'c2900' 


    ----------------------------------------------------------------
    Technology    Technology-package          Technology-package
                  Current       Type          Next reboot  
    -----------------------------------------------------------------
    ipbase        ipbasek9      Permanent     ipbasek9
    security      None          None          None
    uc            None          None          None
    data          None          None          None


    Configuration register is 0x2102


    2911-1#

    2911-1#sh diag | incl FRU
    Product (FRU) Number     : CISCO2911/K9
    Product (FRU) Number     : PWR-2911-AC
    Product (FRU) Number     : SM-SRE-900-K9
    2911-1#



    2911-1#service-module SM 1/0 status
    Service Module is Cisco SM1/0
    Service Module supports session via TTY line 67
    Service Module is trying to recover from error
    Service Module heartbeat-reset is enabled
    Service Module is in fail open
    Service Module status is not available
    No install/uninstall in progress


    Local Partition Info
    =====================
      Please reset module to retrieve
      partition information if needed


    2911-1#



    Thanks


    Mohamed

    Subject: RE: New Message from Mohamed Rafi Meetheen in Service Ready Engine Virtuali
    Replied by: Anurag Gurtu on 20-11-2010 01:33:43 AM
    Can you do the following



    1.       Unplug the power cable from the router

    2.       Plug it back in

    3.       Wait for the router to boot-up

    4.       Session into SRE

    5.       Configure the network

    6.       Install SRE-V image using IOS CLI

    Subject: RE: New Message from Mohamed Rafi Meetheen in Service Ready Engine Virtuali
    Replied by: Radhika Miriyala on 20-11-2010 01:33:43 AM
    Hi Mohamed,

    If the steps suggested by Anurag do not help then can you give me the following information:

    1)      What do you have running on the SRE? Was there an application running on it.

    2)      When you say you could not access the SRE do you mean from the router or from externally?  Does a ping to the SRE from the router work?

    3)      Can you session in to the SRE ? (use command service-module sm 1/0 session).

    Thanks,

    Rdahika

    Subject: RE: New Message from Radhika Miriyala in Service Ready Engine Virtualizatio
    Replied by: Radhika Miriyala on 20-11-2010 01:33:44 AM
    One more thing. Can you give me the status of the SRE. Use the Cli 'service-module sm 1/0 status' and send us the output of that CLI.

    Subject: RE: New Message from Mohamed Rafi Meetheen in Service Ready Engine Virtuali
    Replied by: Mohamed Rafi Meetheen on 20-11-2010 01:33:44 AM
    Hi,
     
    After the power cycle, I am able to session into the SRE and boot ESXi. I am able to ping the outside network, but Vmware client count not connect to that.
     
    I would like to reinstall every thing in the SRE, how should we don that ?
     
    The SRE can be accessed from 10.89.99.152 2056
     
    Thanks
     
    Mohamed Rafi Meetheen

    Subject: RE: New Message from Mohamed Rafi Meetheen in Service Ready Engine Virtuali
    Replied by: Radhika Miriyala on 20-11-2010 01:33:44 AM
    Hi Mohamed,

    You can reinstall the software following the steps below.

    1)Please make sure you have a ftp server that is accessible from the router and the SRE.

    2)Then copy the image files into the a directory on the ftp server.

    3) use the following cli from the router: service-module sm 1/0 install url ftp://<ip address of ftpserver>/<dir where install files are present>/sre-v-k9.smv.1.0.0.19.pkg



    For detailed steps you can look at the user document.



    Let me know if you have any questions.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, September 14, 2010 3:30 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from Mohamed Rafi Meetheen in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from Mohamed Rafi Meetheen in Service Ready Engine Virtuali



    Mohamed Rafi Meetheen has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    Hi,

    After the power cycle, I am able to session into the SRE and boot ESXi. I am able to ping the outside network, but Vmware client count not connect to that.

    I would like to reinstall every thing in the SRE, how should we don that ?

    The SRE can be accessed from 10.89.99.152 2056

    Thanks

    Mohamed Rafi Meetheen
    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2537587>
    or simply reply to this email.