SW installation failed module not responding

Version 1
    This document was generated from CDN thread

    Created by: Kin Cho on 20-11-2010 01:33:42 AM
    Hi,

    I'm trying to install sre-v for the first time, and keep running into this error.
    We've previously successfully installed AXP on this SRE-900 blade.

    Any suggestions is appreciated!

    -kin


    eng-lab-417#service-module SM1/0 install url ftp://10.32.1.124/sre-v-k9.smv.1.0.0.19.pkg
    $install url ftp://10.32.1.124/sre-v-k9.smv.1.0.0.19.pkg
    Delete the installed Application eXtension Platform (AXP) and proceed with new installation? : yes
    Loading sre-v-k9.smv.1.0.0.19.pkg.install.sre !
    [OK - 1692/4096 bytes]

    Service module installation
    ios_version     15.0(1)M,
    ios_image     c2900-universalk9-mz
    pkg_name     sre-v-k9.smv.1.0.0.19.pkg
    key_file     sre-v-k9.smv.1.0.0.19.key
    helper_file     sre-v-installer.smv.1.0.0.19

    Check target platform capabilities
    cpu      1865
    Resource check completed successfully. Proceeding to Install....

    eng-lab-417#
    Sep 10 00:36:35.122: %SM_INSTALL-6-INST_RESET: SM1/0 is reset for software installation.
    Sep 10 00:37:35.122: %SM_INSTALL-3-INST_NORESP: SM1/0 SW installation failed module not responding
    Sep 10 00:37:44.346: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    eng-lab-417#
    eng-lab-417#show diag | include FRU
        Product (FRU) Number     : CISCO2921/K9
        Product (FRU) Number     : PWR-2921-51-AC
        Product (FRU) Number     : SM-SRE-900-K9
    eng-lab-417#

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Anurag Gurtu on 20-11-2010 01:33:42 AM
    Power cycle the router and start with uninstalling AXP. Once uninstalled, issue install command to install SRE-V

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Kin Cho on 20-11-2010 01:33:42 AM
    Thanks for your suggestion, however somehow AXP can't be uninstalled on our blade.

    I've tried the following 3 times with powercycling without success.

    -kin

    eng-lab-417#service-module SM1/0 uninstall force
    eng-lab-417#
    *Sep 10 01:23:29.087: %SM_INSTALL-6-INST_SHUTDOWN: SM1/0 is shutdown for software uninstallation.

    Service module in slot 1 shutting down in 105 seconds...

    Service Module SM1/0 started reload/reset.

    *Sep 10 01:25:29.687: %SM_INSTALL-6-INST_RESET: SM1/0 is reset for software uninstallation.
    *Sep 10 01:25:16.101: %SM_INSTALL-3-INST_NORESP: SM1/0 SW uninstallation failed module not responding
    *Sep 10 01:25:29.185: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    eng-lab-417#
    eng-lab-417#service-module SM1/0 status
    Service Module is Cisco SM1/0
    Service Module supports session via TTY line 67
    Service Module is trying to recover from error
    Service Module heartbeat-reset is enabled
    Service Module status is not available
    No install/uninstall in progress

    eng-lab-417#service-module SM1/0 reset
    Use reset only to recover from shutdown or failed state
    Warning: May lose data on the the NVRAM, nonvolatile file system or unsaved configuration!
    Do you want to reset?

    Trying to reload Service Module SM1/0.

    eng-lab-417#
    *Sep 10 01:27:46.185: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    eng-lab-417#
    eng-lab-417#service-module SM1/0 status
    Service Module is Cisco SM1/0
    Service Module supports session via TTY line 67
    Service Module is in Steady state
    Service Module heartbeat-reset is enabled
    Getting status from the Service Module, please wait..
    Application eXtension Platform (AXP) 1.5.2
    Online on SME
    No install/uninstall in progress

    eng-lab-417#

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Kin Cho on 20-11-2010 01:33:42 AM
    The same issue is seen on our SRE-700 blade.

    -kin

    eng-lab-417#service-module SM1/0 uninstall
    Delete the installed Application eXtension Platform (AXP) permanently? : yes
    eng-lab-417#
    *Sep 10 02:27:03.987: %SM_INSTALL-6-INST_SHUTDOWN: SM1/0 is shutdown for software uninstallation.

    Service module in slot 1 shutting down in 105 seconds...

    Service Module SM1/0 started reload/reset.

    *Sep 10 02:29:04.587: %SM_INSTALL-6-INST_RESET: SM1/0 is reset for software uninstallation.
    *Sep 10 02:28:50.799: %SM_INSTALL-3-INST_NORESP: SM1/0 SW uninstallation failed module not responding
    *Sep 10 02:29:01.115: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    eng-lab-417#
    eng-lab-417#show diag | include FRU
        Product (FRU) Number     : CISCO2921/K9
        Product (FRU) Number     : PWR-2921-51-AC
        Product (FRU) Number     : SM-SRE-700-K9
    eng-lab-417#

    Subject: Re: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Anurag Gurtu on 20-11-2010 01:33:42 AM
    Did you completely unplug the router. Please do so once and then show the output of service module status command.

    Subject: RE: Re: New Message from Kin Cho in Service Ready Engine Virtualization - S
    Replied by: Kin Cho on 20-11-2010 01:33:42 AM
    I've unplugged and here's the output.
     
     
    eng-lab-417#service-module SM1/0 status
    Service Module is Cisco SM1/0
    Service Module supports session via TTY line 67
    Service Module is in Steady state
    Service Module heartbeat-reset is enabled
    Getting status from the Service Module, please wait..
    Application eXtension Platform (AXP) 1.5.2
    Online on SME
    No install/uninstall in progress

    eng-lab-417#
     

    Subject: Re: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Anurag Gurtu on 20-11-2010 01:33:42 AM
    The output looks good.

    Now can you issue service module sm 1/0 uninstall force command and let us know what happens.

    Subject: RE: Re: New Message from Kin Cho in Service Ready Engine Virtualization - S
    Replied by: Kin Cho on 20-11-2010 01:33:43 AM
    The output is still the same... do you think there is an issue with the blade?

    eng-lab-417#
    eng-lab-417#service-module SM1/0 uninstall force
    eng-lab-417#
    Sep 10 05:30:52.216: %SM_INSTALL-6-INST_SHUTDOWN: SM1/0 is shutdown for software uninstallation.

    Service module in slot 1 shutting down in 105 seconds...

    Service Module SM1/0 started reload/reset.

    Sep 10 05:32:52.816: %SM_INSTALL-6-INST_RESET: SM1/0 is reset for software uninstallation.
    Sep 10 05:33:52.816: %SM_INSTALL-3-INST_NORESP: SM1/0 SW uninstallation failed module not responding
    Sep 10 05:34:02.704: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    eng-lab-417#
    eng-lab-417# service-module SM1/0 status
    Service Module is Cisco SM1/0
    Service Module supports session via TTY line 67
    Service Module is in Steady state
    Service Module heartbeat-reset is enabled
    Getting status from the Service Module, please wait..
    Application eXtension Platform (AXP) 1.5.2
    Online on SME
    No install/uninstall in progress

    eng-lab-417#

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Michael Kinzlmaier on 20-11-2010 01:33:43 AM
    Hi Kin,

    Can you try not using the 'force' option ?

    Thanks

    Mike

    Subject: RE: New Message from Michael Kinzlmaier in Service Ready Engine Virtualizat
    Replied by: Michael Kinzlmaier on 20-11-2010 01:33:43 AM
    Hi Kin,

    Can you tell me what version IOS you are using ?

    There were some issues with uninstall with earlier IOS versions.

    Mike

    Subject: RE: New Message from Michael Kinzlmaier in Service Ready Engine Virtualizat
    Replied by: Kin Cho on 20-11-2010 01:33:43 AM
    Hi Mike, it is as follows, also included full version info below.
     
    Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.0(1)M, RELEASE SOFTWARE (fc2)
     
    Thanks,
     
    -kin
     
     
    eng-lab-417#show version
    Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.0(1)M, RELEASE SOFTWARE (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2009 by Cisco Systems, Inc.
    Compiled Wed 30-Sep-09 05:30 by prod_rel_team

    ROM: System Bootstrap, Version 15.0(1r)M1, RELEASE SOFTWARE (fc1)

    eng-lab-417 uptime is 11 hours, 45 minutes
    System returned to ROM by power-on
    System restarted at 05:07:11 UTC Fri Sep 10 2010
    System image file is "flash0:c2900-universalk9-mz.SPA.150-1.M.bin"


    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.

     --More-- q

    eng-lab-417#

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Radhika Miriyala on 20-11-2010 01:33:43 AM
    Kim,

    Can you please change the IOS image to the one that is posted along with the Beta SRE-V Image.

    Thanks,

    Radhika

    Subject: RE: New Message from Kin Cho in Service Ready Engine Virtualization - SRE-V
    Replied by: Kin Cho on 20-11-2010 01:33:43 AM
    Hi Radhika,

    Upgrading IOS got me pass the uninstall issue, and SRE-V is successfully installed.

    Thanks a lot for your tip!

    -kin

    eng-lab-417#service-module SM1/0 status
    Service Module is Cisco SM1/0
    Service Module supports session via TTY line 67
    Service Module is in Steady state
    Service Module heartbeat-reset is enabled
    Getting status from the Service Module, please wait..
    Cisco SRE-V Software 1.0.0.19
    SRE-V Running on SMV
    No install/uninstall in progress

    No local partition

    eng-lab-417#