Loading the SRE with ESXi

Version 1
    This document was generated from CDN thread

    Created by: SCOTT PITTS on 20-11-2010 01:33:39 AM
    I have tried many things at this point to attempt to get the software loaded on the SRE. The two most recenct SRE's were apparently shipped with nothing on them and I believe the first one we got had the AXP image on it. The first one is loaded but these two SRE's do not seem to be co-operating. These 2 SREs will load the TFTP boot image but then have the following message.
     
    disk:bzImage ... done
    Loading Disk:/cmdlineextra ... done
    Verifying ... Verifying application key failed, ret=0
    done
    Starting Kernel
     
    and then reboots over and over.
     
    the FTP/TFTP server is on a different subnet than the SRE. I have tried to use the Internal interface with the static route to the IP to utlize the same net as GIG0/0. I tried NATing it from a GIG0/0 address to a internal address that I put on the SM1/0. I tried using the config command on the SRE and using the external interface.
     
    This is on a Cisco 2911sec/k9 with an SRE900.

    Subject: Automatisch antwoord: New Message from SCOTT PITTS in Service Ready Engine
    Replied by: Stefan de Kooter on 20-11-2010 01:33:39 AM
    ¿
    Geachte dame/heer,

    Tot maandag 27 september ben ik niet aanwezig en heb ik geen toegang tot e-mail en voicemail. Een reactie op uw bericht kunt u na deze datum verwachten

    Wilt u een nieuw ticket aanmelden of een bestaand probleem escaleren, stuur uw bericht dan naar helpdesk@proxsys.nl.

    Met vriendelijke groet,

    Stefan de Kooter
    Projects

    PROXSYS*

    Spijksedijk 16H
    4207 GN  Gorinchem
    K.V.K. 11051004

    T  0183 - 645 080
    F  0183 - 645 081
    I   www.proxsys.nl<http://www.proxsys.nl/>

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Anurag Gurtu on 20-11-2010 01:33:39 AM
    Which application are you trying to install on SRE?

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Radhika Miriyala on 20-11-2010 01:33:39 AM
    Scott,

    A few questions. How are you installing the image? Are you using the SRE install CLI¿ Service-module sm x/0 install url ftp://<ip address>/<image directory>  to install? Or are you using the old method of boot helper to install?

    Can you also provide the console log of the whole install process so we can take a look to see where exactly the system fails.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Wednesday, September 08, 2010 6:44 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from SCOTT PITTS in Service Ready Engine Virtualization - SRE-V Beta Testing: Loading the SRE with ESXi



    SCOTT PITTS has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    I have tried many things at this point to attempt to get the software loaded on the SRE. The two most recenct SRE's were apparently shipped with nothing on them and I believe the first one we got had the AXP image on it. The first one is loaded but these two SRE's do not seem to be co-operating. These 2 SREs will load the TFTP boot image but then have the following message.

    disk:bzImage ... done
    Loading Disk:/cmdlineextra ... done
    Verifying ... Verifying application key failed, ret=0
    done
    Starting Kernel

    and then reboots over and over.

    the FTP/TFTP server is on a different subnet than the SRE. I have tried to use the Internal interface with the static route to the IP to utlize the same net as GIG0/0. I tried NATing it from a GIG0/0 address to a internal address that I put on the SM1/0. I tried using the config command on the SRE and using the external interface.

    This is on a Cisco 2911sec/k9 with an SRE900.
    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2515364>
    or simply reply to this email.

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:39 AM
    Here is the output from the attempted load of the SRE with the ESXi image followed by a show config. I hope this helps.
     
    Router#$l ftp://pittssc:cisco7500@10.10.97.51/sre-v-k9.smv.1.0.0.19.pkg
    Proceed with installation? : y
    Loading sre-v-k9.smv.1.0.0.19.pkg.install.sre !
    [OK - 1757/4096 bytes]
    Service module installation
    ios_version     15.0(1)M2,
    ios_image       c2900-universalk9-mz
    pkg_name        sre-v-k9.smv.1.0.0.19.pkg
    key_file        sre-v-k9.smv.1.0.0.19.key
    helper_file     sre-v-installer.smv.1.0.0.19
    Check target platform capabilities
    cpu      1865
    Resource check completed successfully. Proceeding to Install....
    Router#
    *Sep  8 18:07:13.006: %SM_INSTALL-6-INST_RESET: SM1/0 is reset for software installation.
    [Resuming connection 1 to 192.168.75.5 ... ]
     

    Initializing memory. Please wait...
     

    Initializing memory. Please wait...
    4,290,379,776 bytes of system memory tested OK
    Channel 0 Master : Hitachi HTE545050B9A300                
    Channel 1 Master : Hitachi HTE545050B9A300                
    DDR Memory 4096 MB detected
    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz
    BIOS SM 2.4,  BIOS Build date: 11/04/2009
    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz
    BIOS SM 2.4,  BIOS Build date: 11/04/2009
    System now booting...
     
    Please wait... 
    Please press P to select Primary Boot Loader ...  
              or S to select Secondary Boot Loader ...  
              or wait to boot from default configuration ...  
    .......................................................................................................
    Now booting from primary boot loader....  

    Authenticating boot loader....  

    Primary Boot Loader Authenticated - booting....  
     
    Please enter '***' to change boot configuration:
    Detect and Initialze network device

    Backup current platform configurations....
    SRE step 1 - SM registration...
    SRE step 2 - SM requests key file info...
    *Sep  8 18:07:58.630: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    *Sep  8 18:07:58.634: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP File Request
    SRE step 3 - SM stores registration info...
    SRE configuration keeps the same. No flash update needed!
    SRE step 4 - SM downloads key-file...
    Writing keyfile to flash Size 919
    writing complete.
    Updating flash with bootloader configuration.
    Please wait .................. done.
    SRE step 5 - SM requests installer info...
    *Sep  8 18:08:05.486: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP File Request
    SRE step 6 - SM stores installer info...
    Updating flash with bootloader configuration.
    Please wait .................. done.
    SRE step 7 - SM now downloads installer
    done.
    SRE step 8 - SM requests tcl header file info...
    *Sep  8 18:08:21.194: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP File Request
    SRE step 9 - SM now downloads the tcl header file
    TCL header file downloaded completely size: 698
    SRE step 10 - SM requests tcl file info...
    *Sep  8 18:08:26.674: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP File Request
    SRE step 11 - SM now downloads the tcl file
    TCL file downloaded completely size: 1757
    SRE step 12 - SM now boots Installer
    Verifying ... Verifying application key failed, ret=0
    done.
    Starting Kernel.
    þ
     
    Initializing memory. Please wait...
     

    Initializing memory. Please wait...
    4,290,379,776 bytes of system memory tested OK
    Channel 0 Master : Hitachi HTE545050B9A300                
    Channel 1 Master : Hitachi HTE545050B9A300                
    DDR Memory 4096 MB detected
    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz
    BIOS SM 2.4,  BIOS Build date: 11/04/2009
    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz
    BIOS SM 2.4,  BIOS Build date: 11/04/2009
    System now booting...
     
    Please wait... 
    Please press P to select Primary Boot Loader ...  
              or S to select Secondary Boot Loader ...  
              or wait to boot from default configuration ...  
    .......................................................................................................
    Now booting from primary boot loader....  

    Authenticating boot loader....  

    Primary Boot Loader Authenticated - booting....  
     
    Please enter '***' to change boot configuration:
    Detect and Initialze network device

    Backup current platform configurations....
    SRE step 1 - SM registration...
    Verification error occurred, cancelling installation
    Updating flash with bootloader configuration.
    Please wait .................. done.
    *Sep  8 18:09:17.630: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Error message(code:0) Keyfile Verification Failed received on SM1/0
    SRE Step 1 complete ending installation
    *Sep  8 18:09:19.958: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Error Msg Req
    *Sep  8 18:09:19.958: %SM_INSTALL-6-RBIP_ERROR: Error message(code:0) Keyfile Verification Failed received on SM1/0
     ServicesEngine Bootloader Version : 2.1.27

    ServicesEngine boot-loader>    

    Initializing memory. Please wait...
     

    Initializing memory. Please wait...
    4,290,379,776 bytes of system memory tested OK
    Channel 0 Master : Hitachi HTE545050B9A300                
    Channel 1 Master : Hitachi HTE545050B9A300                
    DDR Memory 4096 MB detected
    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz
    BIOS SM 2.4,  BIOS Build date: 11/04/2009
    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz
    BIOS SM 2.4,  BIOS Build date: 11/04/2009
    System now booting...
     
    Please wait... 
    Please press P to select Primary Boot Loader ...  
              or S to select Secondary Boot Loader ...  
              or wait to boot from default configuration ...  
    .......................................................................................................
    Now booting from primary boot loader....  

    Authenticating boot loader....  

    Primary Boot Loader Authenticated - booting....  
     
    Please enter '***' to change boot configuration:
    Detect and Initialze network device

    Backup current platform configurations....
    SRE step 1 - SM registration
     Abort successful on SM1/0
    ...
    Response - no installation needed (len: 422)
    SRE Installation Not Needed

    Restoring orignial configuration...
    Updating flash with bootloader configuration.
    Please wait .................. done.
    *Sep  8 18:10:35.630: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    *Sep  8 18:10:35.630: %SM_INSTALL-6-INST_ABORT: SM1/0 SW installation aborted, reason:user command
     ServicesEngine Bootloader Version : 2.1.27

    ServicesEngine boot-loader>  
     
    Show Config

    Initializing memory. Please wait...
     

    Initializing memory. Please wait...
    4,290,379,776 bytes of system memory tested OK
    Channel 0 Master : Hitachi HTE545050B9A300                
    Channel 1 Master : Hitachi HTE545050B9A300                
    DDR Memory 4096 MB detected
    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz
    BIOS SM 2.4,  BIOS Build date: 11/04/2009
    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz
    BIOS SM 2.4,  BIOS Build date: 11/04/2009
    System now booting...
     
    Please wait... 
    Please press P to select Primary Boot Loader ...  
              or S to select Secondary Boot Loader ...  
              or wait to boot from default configuration ...  
    .......................................................................................................
    Now booting from primary boot loader....  

    Authenticating boot loader....  

    Primary Boot Loader Authenticated - booting....  
     
    Please enter '***' to change boot configuration:
    Detect and Initialze network device

    Backup current platform configurations....
    SRE step 1 - SM registration
     Abort successful on SM1/0
    ...
    Response - no installation needed (len: 422)
    SRE Installation Not Needed

    Restoring orignial configuration...
    Updating flash with bootloader configuration.
    Please wait .................. done.
    *Sep  8 18:10:35.630: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    *Sep  8 18:10:35.630: %SM_INSTALL-6-INST_ABORT: SM1/0 SW installation aborted, reason:user command
     ServicesEngine Bootloader Version : 2.1.27

    ServicesEngine boot-loader>  

    ************************************************SHOW CONFIG*********************************************************
    Router#show config
    Using 1941 out of 262136 bytes
    !
    ! Last configuration change at 21:11:55 UTC Tue Sep 7 2010
    !
    version 15.0
    service config
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    !
    !
    memory-size iomem 20
    !
    no ipv6 cef
    ip source-route
    ip cef
    !
    !
    !
    !
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    license udi pid CISCO2911/K9 sn FTX1429A35B
    hw-module sm 1
    !
    !
    !
    vtp version 2
    !
    redundancy
    !
    !
    !
    !        
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
     ip address dhcp
     ip nat outside
     ip virtual-reassembly
     duplex auto
     speed auto
     !
    !
    interface GigabitEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
     !
    !
    interface GigabitEthernet0/2
     no ip address
     shutdown
     duplex auto
     speed auto
     !
    !
    interface FastEthernet0/3/0
     !
    !
    interface FastEthernet0/3/1
     !
    !
    interface FastEthernet0/3/2
     !
    !
    interface FastEthernet0/3/3
     !
    !
    interface FastEthernet0/3/4
     !
    !
    interface FastEthernet0/3/5
     !
    !
    interface FastEthernet0/3/6
     !
    !
    interface FastEthernet0/3/7
     !
    !
    interface FastEthernet0/3/8
     !
    !
    interface SM1/0
     ip address 192.168.75.5 255.255.255.0
     ip nat inside
     ip virtual-reassembly
     service-module fail-open
     service-module ip address 192.168.75.98 255.255.255.0
     service-module ip default-gateway 192.168.75.99
     !
    !
    interface SM1/1
     no ip address
     !
    !
    interface Cellular0/1/0
     no ip address
     encapsulation ppp
     !
    !
    interface Vlan1
     no ip address
     !
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    ip nat inside source static 192.168.75.6 10.11.16.98
    ip nat inside source static 192.168.75.5 10.11.16.99
    !
    !
    !
    !
    !
    !
    !
    control-plane
     !       
    !
    !
    line con 0
    line aux 0
    line 0/1/0
     no exec
    line 67
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
     flowcontrol software
    line vty 0 4
     login
    !
    scheduler allocate 20000 1000
    end
    Router# 
     
     

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Radhika Miriyala on 20-11-2010 01:33:40 AM
    Scott,

    Thanks for the logs. It looks like a key verification issue. One thing I noticed is  in step 4 of the sre install it writes a key file into the flash and in your case the key size is 919 but it should be 916 bytes. Can you please download the key file  (sre-v-k9.smv.1.0.0.19.key )may be even the whole package once again and try? How are you copying the files to your ftp server.



    Thanks

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Ashwin Venkatesan on 20-11-2010 01:33:40 AM
    Hi Scott,



    Can you check if you have the key file (sre-v-k9.smv.x.x.x..key in your ftp server). If you have it can you recopy the file and try again



    Thanks,

    Ashwin

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Anurag Gurtu on 20-11-2010 01:33:40 AM
    I will also suggest you to upgrade the IOS image to the one uploaded on CDN and then configure service-module mgf ip address and gateway.



    -Anurag

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:40 AM
    I will also suggest you to upgrade the IOS image to the one uploaded on CDN and then configure service-module mgf ip address and gateway.



    -Anurag


    The FTP server is a windows box (CiscoWorks) with FTP and TFTP. I downloaded if from the console this time. Within Winzip is sais the key file is 916 bytes but once it is extracted it is 919bytes. The first time it was extracted on my workstation and copied via a file share. Re-downloading did not make a difference.
     
     
    I have the Beta 2911 image on another 2911 and it performs the same way, just dont have to NAT it.
     
     

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Brett Tiller on 20-11-2010 01:33:40 AM
    Hi Scott,

    When using Winzip to extract files be sure to turn off the Smart Tar feature or it can corrupt files.  Here's some more information on it.

    http://developer.cisco.com/web/axp/blogroll/-/blogs/be-careful-with-winzip?_33_redirect=%2Fweb%2Faxp%2Fblogroll

    Thanks,

    Brett

    Custom Application Engineer
    http://developer.cisco.com/web/axp/home

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:40 AM
    It would appear that WinZip was the culpret but I still can not load the SRE. Now it download everything and reboots and then fails installing the package because it can not reach the FTP server, although it just pulled all those files from it.

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Brett Tiller on 20-11-2010 01:33:40 AM
    Scott,

    Glad we got one issue figured out.  Please include the messages being displayed so we can analyze exactly what is occurring on your system.

    Thanks,

    Brett

    Custom Application Engineer
    http://developer.cisco.com/web/axp/home

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:40 AM
    It is really is ugly that I had to route a network to the router just to load the SRE, but it appears to be the only way as my attempt to NAT did not work. I used the config another post on this forum and left of the VLANs and routed the network to the module. I then tried to load the SRE again. It appears to have done something different and may have even loaded the ESXi image. Seems to be stuck on loading MgmtVM, but maybe it is up and running.
     
     
    rbcp:    INFO rbcp daemon output module = 4
    rbcp:    INFO rbcp daemon output product/name doesn't exist
    rbcp:    INFO rbcp daemon output bryce registration message information:
    rbcp:    INFO rbcp daemon output length: (89,1493172224), version (1,0), app_name(Cisco Foundation Software), app_ver(1.0), subsys_id (0), app_status (FNDN Running on SM), capability (1289), app_cookie_id (SM-SRE-900-K9)
    rbcp:    INFO rbcp daemon output rbcp_dump raw message: sent, opcode = 0x13
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x0e 0xff 0x00 0x5d 0x01 0x00 0x00 0x13 0xb0 0xd7 0x04 0x08 0xb0 0xd7 0x04 0x08
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x00 0x00 0x00 0x59 0x54 0x4c 0x56 0x2d 0x54 0x59 0x50 0x45 0x01 0x00 0x10 0x19
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x43 0x69 0x73 0x63 0x6f 0x20 0x46 0x6f 0x75 0x6e 0x64 0x61 0x74 0x69 0x6f 0x6e
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x20 0x53 0x6f 0x66 0x74 0x77 0x61 0x72 0x65 0x20 0x03 0x31 0x2e 0x30 0x30 0x01
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x00 0x40 0x00 0x00 0x00 0x12 0x46 0x4e 0x44 0x4e 0x20 0x52 0x75 0x6e 0x6e 0x69
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x6e 0x67 0x20 0x6f 0x6e 0x20 0x53 0x4d 0x50 0x04 0x00 0x00 0x05 0x09 0x60 0x0d
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x53 0x4d 0x2d 0x53 0x52 0x45 0x2d 0x39 0x30 0x30 0x2d 0x4b 0x39
    rbcp:    INFO rbcp daemon output current platform sm
    rbcp:    INFO rbcp daemon output app_cookie_id from sysdb = SM-SRE-900-K9
    rbcp:    INFO rbcp daemon output ios_image_type1 from sysdb = 0
    rbcp:    INFO rbcp daemon output ios_image_type2 from sysdb = 0
    rbcp:    INFO rbcp daemon output app_capability from sysdb = 1289
    rbcp:    INFO rbcp daemon output subsys_id from sysdb = 0
    rbcp:    INFO rbcp daemon output rsrcmgr: moduleplatno: 4
    rbcp:    INFO rbcp daemon output rsrcmgr: rbcpmsg_fmt: 1
    rbcp:    INFO rbcp daemon output rbcp_register - SCP register, Version 2.6.22.10-vs2.2.0.5-cisco-smv
    rbcp:    INFO rbcp daemon output Copyright (c) 1999-2009 by Cisco Systems, Inc.
    rbcp:    INFO rbcp daemon output All rights reserved.
    rbcp:    INFO rbcp daemon output product/name doesn't exist
    rbcp:    INFO rbcp daemon output module type is 4
    rbcp:    INFO rbcp daemon output got configured variables:
    rbcp:    INFO rbcp daemon output ios_image_type1 = 0
    rbcp:    INFO rbcp daemon output ios_image_type2 = 0
    rbcp:    INFO rbcp daemon output capability = 1289
    rbcp:    INFO rbcp daemon output subsys_id = 0
    rbcp:    INFO rbcp daemon output app_cookie_id = SM-SRE-900-K9
    rbcp:    INFO rbcp daemon output module = 4
    add_file /mnt/dwnld/pkgdata/sre-v-k9.smv.1.0.0.19.pkg 8 /mivmdk sw/installed/manifest/installer_manifest.sig none
    rbcp:    INFO rbcp daemon output product/name doesn't exist
    rbcp:    INFO rbcp daemon output bryce registration message information:
    rbcp:    INFO rbcp daemon output length: (89,1493172224), version (1,0), app_name(Cisco Foundation Software), app_ver(1.0), subsys_id (0), app_status (FNDN Running on SM), capability (1289), app_cookie_id (SM-SRE-900-K9)
    rbcp:    INFO rbcp daemon output rbcp_dump raw message: sent, opcode = 0x13
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x0e 0xff 0x00 0x5d 0x01 0x00 0x00 0x13 0xb0 0xd7 0x04 0x08 0xb0 0xd7 0x04 0x08
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x00 0x00 0x00 0x59 0x54 0x4c 0x56 0x2d 0x54 0x59 0x50 0x45 0x01 0x00 0x10 0x19
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x43 0x69 0x73 0x63 0x6f 0x20 0x46 0x6f 0x75 0x6e 0x64 0x61 0x74 0x69 0x6f 0x6e
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x20 0x53 0x6f 0x66 0x74 0x77 0x61 0x72 0x65 0x20 0x03 0x31 0x2e 0x30 0x30 0x01
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x00 0x40 0x00 0x00 0x00 0x12 0x46 0x4e 0x44 0x4e 0x20 0x52 0x75 0x6e 0x6e 0x69
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x6e 0x67 0x20 0x6f 0x6e 0x20 0x53 0x4d 0x50 0x04 0x00 0x00 0x05 0x09 0x60 0x0d
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x53 0x4d 0x2d 0x53 0x52 0x45 0x2d 0x39 0x30 0x30 0x2d 0x4b 0x39
    rbcp:    INFO rbcp daemon output current platform sm
    rbcp:    INFO rbcp daemon output app_cookie_id from sysdb = SM-SRE-900-K9
    rbcp:    INFO rbcp daemon output ios_image_type1 from sysdb = 0
    rbcp:    INFO rbcp daemon output ios_image_type2 from sysdb = 0
    rbcp:    INFO rbcp daemon output app_capability from sysdb = 1289
    rbcp:    INFO rbcp daemon output subsys_id from sysdb = 0
    rbcp:    INFO rbcp daemon output rsrcmgr: moduleplatno: 4
    rbcp:    INFO rbcp daemon output rsrcmgr: rbcpmsg_fmt: 1
    rbcp:    INFO rbcp daemon output rbcp_register - SCP register, Version 2.6.22.10-vs2.2.0.5-cisco-smv
    rbcp:    INFO rbcp daemon output Copyright (c) 1999-2009 by Cisco Systems, Inc.
    rbcp:    INFO rbcp daemon output All rights reserved.
    rbcp:    INFO rbcp daemon output product/name doesn't exist
    rbcp:    INFO rbcp daemon output module type is 4
    rbcp:    INFO rbcp daemon output got configured variables:
    rbcp:    INFO rbcp daemon output ios_image_type1 = 0
    rbcp:    INFO rbcp daemon output ios_image_type2 = 0
    rbcp:    INFO rbcp daemon output capability = 1289
    rbcp:    INFO rbcp daemon output subsys_id = 0
    rbcp:    INFO rbcp daemon output app_cookie_id = SM-SRE-900-K9
    rbcp:    INFO rbcp daemon output module = 4
    rbcp:    INFO rbcp daemon output product/name doesn't exist
    rbcp:    INFO rbcp daemon output bryce registration message information:
    rbcp:    INFO rbcp daemon output length: (89,1493172224), version (1,0), app_name(Cisco Foundation Software), app_ver(1.0), subsys_id (0), app_status (FNDN Running on SM), capability (1289), app_cookie_id (SM-SRE-900-K9)
    rbcp:    INFO rbcp daemon output rbcp_dump raw message: sent, opcode = 0x13
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x0e 0xff 0x00 0x5d 0x01 0x00 0x00 0x13 0xb0 0xd7 0x04 0x08 0xb0 0xd7 0x04 0x08
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x00 0x00 0x00 0x59 0x54 0x4c 0x56 0x2d 0x54 0x59 0x50 0x45 0x01 0x00 0x10 0x19
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x43 0x69 0x73 0x63 0x6f 0x20 0x46 0x6f 0x75 0x6e 0x64 0x61 0x74 0x69 0x6f 0x6e
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x20 0x53 0x6f 0x66 0x74 0x77 0x61 0x72 0x65 0x20 0x03 0x31 0x2e 0x30 0x30 0x01
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x00 0x40 0x00 0x00 0x00 0x12 0x46 0x4e 0x44 0x4e 0x20 0x52 0x75 0x6e 0x6e 0x69
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x6e 0x67 0x20 0x6f 0x6e 0x20 0x53 0x4d 0x50 0x04 0x00 0x00 0x05 0x09 0x60 0x0d
    add_file /mnt/dwnld/pkgdata/sre-v-k9.smv.1.0.0.19.pkg 4 /mivmdk sw/installed/manifest/oscore_manifest.sig none
    rbcp:    INFO rbcp daemon output rbcp_dump: 0x53 0x4d 0x2d 0x53 0x52 0x45 0x2d 0x39 0x30 0x30 0x2d 0x4b 0x39
    rbcp:    INFO rbcp daemon output current platform sm
    rbcp:    INFO rbcp daemon output app_cookie_id from sysdb = SM-SRE-900-K9
    rbcp:    INFO rbcp daemon output ios_image_type1 from sysdb = 0
    rbcp:    INFO rbcp daemon output ios_image_type2 from sysdb = 0
    rbcp:    INFO rbcp daemon output app_capability from sysdb = 1289
    rbcp:    INFO rbcp daemon output subsys_id from sysdb = 0
    rbcp:    INFO rbcp daemon output rsrcmgr: moduleplatno: 4
    rbcp:    INFO rbcp daemon output rsrcmgr: rbcpmsg_fmt: 1
    rbcp:    INFO rbcp daemon output rbcp_register - SCP register, Version 2.6.22.10-vs2.2.0.5-cisco-smv
    rbcp:    INFO rbcp daemon output Copyright (c) 1999-2009 by Cisco Systems, Inc.
    rbcp:    INFO rbcp daemon output All rights reserved.
    rbcp:    INFO rbcp daemon output product/name doesn't exist
    rbcp:    INFO rbcp daemon output module type is 4
    rbcp:    INFO rbcp daemon output got configured variables:
    rbcp:    INFO rbcp daemon output ios_image_type1 = 0
    rbcp:    INFO rbcp daemon output ios_image_type2 = 0
    rbcp:    INFO rbcp daemon output capability = 1289
    rbcp:    INFO rbcp daemon output subsys_id = 0
    rbcp:    INFO rbcp daemon output app_cookie_id = SM-SRE-900-K9
    rbcp:    INFO rbcp daemon output module = 4
    rbcp:    INFO rbcp daemon output product/name doesn't exist
    rbcp:    INFO rbcp daemon output bryce registration message information:
    rbcp:    INFO rbcp daemon output length: (89,1493172224), version (1,0), app_name(Cisco Foundation Software), app_ver(1.0), subsys_id (0), app_status (FNDN Running on SM), capability (1289), app_cookie_id (SM-SRE-900-K9)
    INIT: Sending processes the TERM signalump raw
    Rebooting ...
    shutdown: sending all processes the TERM signal...
    rbcp:    INFO rbcp daemon output END
    shutdown: sending all processes the KILL signal.
    shutdown: turning off swap
    shutdown: unmounting all file systems
    Please stand by while rebooting the system.
    Restarting system.
    *Sep  9 13:06:20.771: %SM_INSTALL-6-INST_SUCC: SM1/0 SUCCESS: install-completed.
    Install successful on SM1/0
     

    Initializing memory #1. Please wait...
     

    Initializing memory #2. Please wait...

    This may take a minute....

     Serial ATA Port 0 : Hitachi HTE545050B9A300                
     Serial ATA Port 1 : Hitachi HTE545050B9A300                
    DDR Memory 4096 MB detected
    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz
    BIOS SM 3.52.6,  BIOS Build date: 08/03/2010
    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz
    BIOS SM 3.52.6,  BIOS Build date: 08/03/2010
    System now booting...
     
    Please wait... 
    Please press P to select Primary Boot Loader ...  
              or S to select Secondary Boot Loader ...  
              or wait to boot from default configuration ...  
    .......................................................................................................
    SRE module get located and run....  
    New SRE installation detected....  
    Now booting from secondary boot loader....  

    Authenticating boot loader....  

    Secondary Boot Loader authenticated - booting....  

    Updating flash with bootloader configuration.
    Please wait .................. done.
    Updating flash with bootloader configuration.
    Please wait .................. done.

    Please enter '***' to change boot configuration:
    *Sep  9 13:07:47.799: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Status Req
    *Sep  9 13:07:47.799: %SM_INSTALL-6-RBIP_STATUS: SM1/0 RBIP status is at Secondary Bootloader Verified Copying to Primary.
    Detect and Initialze network device

    Backup current platform configurations....
    SRE step 1 - SM registration...
    Response - no installation needed (len: 422)
    SRE Installation Not Needed

    Restoring orignial configuration...
    Updating flash with bootloader configuration.
    Please wait .................. done.
    *Sep  9 13:07:53.739: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Requestgot meta list size: 3, 49, 96, 613
    Verifying ...
    Upgrading...Primary Bootloader
    done.
    Starting Kernel.
    Starting VMKernel initialization ...
    Initializing memory ...
    Initializing chipset ...
    Initializing timing ...
    Initializing scheduler ...
    Initializing device support ...
    Initializing processors ...
    Initializing interrupts ...
    Initializing IOV ...
    Initializing chipset IOAPIC ...
    Enabling interrupts ...
    Initializing ACPI ...
    Initializing Power Management ...
    VMKernel loaded successfully.
    Loading module procfs ...
    procfs loaded successfully.
    Loading module vmkapiv1_0_0_0_vmkernel_shim ...
    vmkapiv1_0_0_0_vmkernel_shim loaded successfully.
    Loading module vmklinux ...
    vmklinux loaded successfully.
    Loading module random ...
    random loaded successfully.
    Loading module usb ...
    usb loaded successfully.
    Loading module ehci-hcd ...
    ehci-hcd loaded successfully.
    Loading module usb-uhci ...
    usb-uhci loaded successfully.
    Loading module hid ...
    hid loaded successfully.
    Loading module dm ...
    dm loaded successfully.
    Loading module nmp ...
    nmp loaded successfully.
    Loading module vmw_satp_local ...
    vmw_satp_local loaded successfully.
    Loading module vmw_satp_default_aa ...
    vmw_satp_default_aa loaded successfully.
    Loading module vmw_psp_lib ...
    vmw_psp_lib loaded successfully.
    Loading module vmw_psp_fixed ...
    vmw_psp_fixed loaded successfully.
    Loading module vmw_psp_rr ...
    vmw_psp_rr loaded successfully.
    Loading module vmw_psp_mru ...
    vmw_psp_mru loaded successfully.
    Loading module vmw_psp_fixed_ap ...
    vmw_psp_fixed_ap loaded successfully.
    Loading module vmw_satp_alua ...
    vmw_satp_alua loaded successfully.
    Loading module vmw_satp_cx ...
    vmw_satp_cx loaded successfully.
    Loading module libata ...
    libata loaded successfully.
    Loading module usb-storage ...
    usb-storage loaded successfully.
    Loading module vfat ...
    vfat loaded successfully.
    Loading module mask_path_plugin ...
    mask_path_plugin loaded successfully.
    Loading module vaai_filter ...
    vaai_filter loaded successfully.
    Loading module vmw_vaaip_emc ...
    vmw_vaaip_emc loaded successfully.
    Loading module vmkapiv1_0_0_0_nmp_shim ...
    vmkapiv1_0_0_0_nmp_shim loaded successfully.
    Loading module vtddmar ...
    vtddmar loaded successfully.
    Loading module vmci ...
    vmci loaded successfully.
    Loading module iscsi_trans ...
    iscsi_trans loaded successfully.
    Loading module hub ...
    hub loaded successfully.
    Loading module netsched ...
    netsched loaded successfully.
    Loading module e1000e ...
    e1000e loaded successfully.
    Loading module bnx2 ...
    bnx2 loaded successfully.
    Loading module cnic ...
    cnic loaded successfully.
    Loading module iscsi_linux ...
    iscsi_linux loaded successfully.
    Loading module bnx2i ...
    bnx2i loaded successfully.
    Loading module ata_piix ...
    ata_piix loaded successfully.
    Loading module lvmdriver ...
    lvmdriver loaded successfully.
    Loading module deltadisk ...
    deltadisk loaded successfully.
    Loading module multiextent ...
    multiextent loaded successfully.
    Loading module dvsdev ...
    dvsdev loaded successfully.
    Loading module etherswitch ...
    etherswitch loaded successfully.
    Loading module shaper ...
    shaper loaded successfully.
    Loading module cdp ...
    cdp loaded successfully.
    Loading module tcpip3 ...
    tcpip3 loaded successfully.
    Loading module dvfilter ...
    dvfilter loaded successfully.
    Loading module vmkapiv1_0_0_0_dvfilter_shim ...
    vmkapiv1_0_0_0_dvfilter_shim loaded successfully.
    Loading module vmkibft ...
    vmkibft loaded successfully.
    Loading module vmfs3 ...
    vmfs3 loaded successfully.
    Loading module nfsclient ...
    nfsclient loaded successfully.
    Loading module vmkstatelogger ...
    vmkstatelogger loaded successfully.
    Loading module migrate ...
    migrate loaded successfully.
    Loading module cbt ...
    cbt loaded successfully.
    Loading module spi ...
    spi loaded successfully.
    Running ntpd start
    Running DCUI start
    Running vprobed start
    Running vobd start
    Running storageRM start
    Running sensord start
    Running lbtd start
    Running hostd start
    Running slpd start
    Running wsman start
    Running usbarbitrator start
    Running sfcbd-watchdog start
    Running cisco-agent start
    cisco-agent: Starting first boot procedure
    cisco-agent: Verifying Cisco MgmtVM H/G vSwitch & portgroup
    cisco-agent: Verifying Cisco MgmtVM network
    cisco-agent: Verifying Cisco MGF network
    cisco-agent: Starting Cisco MgmtVM

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Anurag Gurtu on 20-11-2010 01:33:40 AM
    We currently have a know issue which we are working on where sometimes the loading stops at Management VM. Please issue the following command from IOS



    Service-module sm X/0 reset



    This will reset the module and upon reload it shouldn¿t get stuck at management VM. If it does, please issue reset once again. This issue will be fixed very soon.



    I would like to understand why you are setting up additional routes on the router for SRE installation. Is it due to the fact that FTP server is on a network which is not reachable by SRE?

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:40 AM

    I would like to understand why you are setting up additional routes on the router for SRE installation. Is it due to the fact that FTP server is on a network which is not reachable by SRE?


    The FTP server in not on the same network as the as the GIG0/0 interface. It is a routing issue because I could not seem to get the SRE to be on the same network as the GIG0/0 interface. I tried to put it on an 192.168.75.X network and NAT it to the 10.11.17.x network on GIG0/0. It would load the initial config rebot and then the code install would fail as it could not get to the FTP server.

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:41 AM
    We currently have a know issue which we are working on where sometimes the loading stops at Management VM. Please issue the following command from IOS



    Service-module sm X/0 reset



    This seems to have gotten the SRE back up and running the ESXi image:
     
    Router#SERVice-module SM 1/0 STATUS
    Service Module is Cisco SM1/0
    Service Module supports session via TTY line 67
    Service Module is in Steady state
    Service Module heartbeat-reset is enabled
    Getting status from the Service Module, please wait..
    Cisco SRE-V Software 1.0.0.19
    SRE-V Running on SMV
    No install/uninstall in progress
    Router#
     
    Per the SRE document I should be able to go to the SRE's MGF interface to get the vSpere Client via https. Https does not return anything and http returns a 404 error
     
    http://192.168.75.51
    http://192.168.75.51
     
    <h1>HTTP Status 404 - /admin</h1>
    <hr size="1" noshade="noshade" />
    type Status report
    message /admin
    description The requested resource (/admin) is not available.
    <hr size="1" noshade="noshade" />
    <h3>Apache Tomcat/6.0-snapshot</h3>
    How do I begin managing the ESXi?
     

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Radhika Miriyala on 20-11-2010 01:33:41 AM
    Scott,

    Did you activate the license on the SRE? Can you also please give me the output of cli  ¿show hypervisor ip¿



    Thanks,

    Radhika





    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Thursday, September 09, 2010 9:47 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from SCOTT PITTS in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S



    SCOTT PITTS has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------

    We currently have a know issue which we are working on where sometimes the loading stops at Management VM. Please issue the following command from IOS



    Service-module sm X/0 reset



    This seems to have gotten the SRE back up and running the ESXi image:

    Router#SERVice-module SM 1/0 STATUS
    Service Module is Cisco SM1/0
    Service Module supports session via TTY line 67
    Service Module is in Steady state
    Service Module heartbeat-reset is enabled
    Getting status from the Service Module, please wait..
    Cisco SRE-V Software 1.0.0.19
    SRE-V Running on SMV
    No install/uninstall in progress
    Router#

    Per the SRE document I should be able to go to the SRE's MGF interface to get the vSpere Client via https. Https does not return anything and http returns a 404 error

    http://192.168.75.51


    <h1>HTTP Status 404 - /admin</h1>
    <hr size="1" noshade="noshade" />
    type Status report
    message /admin
    description The requested resource (/admin) is not available.
    <hr size="1" noshade="noshade" />
    <h3>Apache Tomcat/6.0-snapshot</h3>
    How do I begin managing the ESXi?

    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2519349>
    or simply reply to this email.

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:41 AM
    Scott,

    Did you activate the license on the SRE? Can you also please give me the output of cli ¿show hypervisor ip¿



    Thanks,

    Radhika


    That is interesting as it would appear to not have an IP. I did accept the license.  I also can not reload or reset the module and it seen to go into some loop. I have to power cycle the router to get the SRE back running.

    se-192-168-75-51# show hypervisor ip
    Hostname:               localhost
    Domain Name:            None
    IP Config:              169.254.0.1(Subnet Mask: 255.255.0.0)
                            169.254.1.1(Subnet Mask: 255.255.255.0)
    Default Gateway:        None
    Preferred DNS Server:   None
    Alternative DNS Server: None
     
    se-192-168-75-51# show license
    Index 0 Feature: VMIVR-VM-MBX  
            Period left:  8 weeks  4 days
            License Type: Evaluation
            License State: Active, Not in Use, EULA not accepted
            License Count: 250 / 0
            License Priority: None
    Index 1 Feature: TEST_APP1     
            Period left:  1 hour   0 minute 
            License Type: Evaluation
            License State: Active, Not in Use, EULA not accepted
            License Count: Non-Counted
            License Priority: None
    Index 2 Feature: TEST_APP2     
            Period left:  1 day   1 hour 
            License Type: Evaluation
            License State: Active, Not in Use, EULA not accepted
            License Count: Non-Counted
            License Priority: None
    Index 3 Feature: TEST_APP3     
            Period left:  1 week   0 day 
            License Type: Evaluation
            License State: Active, Not in Use, EULA not accepted
            License Count: Non-Counted
            License Priority: None
    Index 4 Feature: TEST_CAPP1    
            Period left:  1 hour   0 minute 
            License Type: Evaluation
            License State: Active, Not in Use, EULA not accepted
            License Count: 250 / 0
            License Priority: None
    Index 5 Feature: TEST_CAPP2    
            Period left:  1 day   1 hour 
            License Type: Evaluation
            License State: Active, Not in Use, EULA not accepted
            License Count: 250 / 0
            License Priority: None
    Index 6 Feature: TEST_CAPP3    
            Period left:  1 hour   0 minute 
            License Type: Evaluation
            License State: Active, Not in Use, EULA not accepted
            License Count: 24 / 0
            License Priority: None
    Index 7 Feature: TEST_CAPP4    
            Period left:  1 day   1 hour 
            License Type: Evaluation
            License State: Active, Not in Use, EULA not accepted
            License Count: 24 / 0
            License Priority: None
    Index 8 Feature: SRE-V-HOST-LIC
            Period left:  8 weeks  3 days
            License Type: Evaluation
            License State: Active, In Use
            License Count: Non-Counted
            License Priority: Low
    se-192-168-75-51#
     
     
    ***** Reloading ****
    se-192-168-75-51# reload
    Reloading the system will terminate all end user sessions.
    Doing a reload will cause any unsaved configuration data to be lost.
    Are you sure you want to reload?
    se-192-168-75-51#
    MONITOR SHUTDOWN...
    INIT: Sending processes the TERM signal
    Shutting down ...
    rbcp:    INFO rbcp daemon output END
    trace:    INFO trace daemon output END
    platform.config:    INFO platform.config server output END
    Power down.
    acpi_power_off called
    Starting VMKernel shutdown ...
    Shutting down file systems drivers ...
    Stopping SCSI Device periodic probe and disabling path probe ...
    Shutting down network devices ...
    Shutting down device drivers ...
    Shutting down APs ...
    *Sep  9 16:55:34.491: %LINK-3-UPDOWN: Interface SM1/1, changed state to down
    *Sep  9 16:55:35.491: %LINEPROTO-5-UPDOWN: Line protocol on Interface SM1/1, changed state to down
     
    Initializing memory #1. Please wait...
     

    Initializing memory #2. Please wait...

    This may take a minute....
    *Sep  9 16:55:39.491: %LINK-3-UPDOWN: Interface SM1/1, changed state to up
    *Sep  9 16:55:40.491: %LINEPROTO-5-UPDOWN: Line protocol on Interface SM1/1, changed state to up
     Serial ATA Port 0 : Hitachi HTE545050B9A300                
     Serial ATA Port 1 : Hitachi HTE545050B9A300                
    DDR Memory 4096 MB detected
    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz
    BIOS SM 3.52.6,  BIOS Build date: 08/03/2010
    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz
    BIOS SM 3.52.6,  BIOS Build date: 08/03/2010
    System now booting...
     
    Please wait... 
    Please press P to select Primary Boot Loader ...  
              or S to select Secondary Boot Loader ...  
              or wait to boot from default configuration ...  
    .......................................................................................................
    SRE module get located and run....  
    Now booting from secondary boot loader....  

    Authenticating boot loader....  

    Secondary Boot Loader authenticated - booting....  
     
    Please enter '***' to change boot configuration:
    Detect and Initialze network device

    Backup current platform configurations....
    SRE step 1 - SM registration...
    *Sep  9 16:56:33.251: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Time-out from RBIP response wait loop
    *Sep  9 16:56:53.071: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Time-out from RBIP response wait loop
    *Sep  9 16:57:12.899: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Time-out from RBIP response wait loop
    *Sep  9 16:57:32.727: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Time-out from RBIP response wait loop
    *Sep  9 16:57:52.555: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Time-out from RBIP response wait loop
    *Sep  9 16:58:12.379: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Time-out from RBIP response wait loop
    *Sep  9 16:58:32.207: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Time-out from RBIP response wait loop
    *Sep  9 16:58:52.035: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Time-out from RBIP response wait loop
    *Sep  9 16:59:11.863: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Time-out from RBIP response wait loop
    *Sep  9 16:59:31.691: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Time-out from RBIP response wait loop
    *Sep  9 16:59:51.519: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Time-out from RBIP response wait loop
    *Sep  9 17:00:11.347: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Time-out from RBIP response wait loop
    *Sep  9 17:00:31.175: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Router#SERVice-module SM 1/0 reset
    Use reset only to recover from shutdown or failed state
    Warning: May lose data on the the NVRAM, nonvolatile file system or unsaved configuration!
    Do you want to reset?
    *Sep  9 17:00:51.003: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Trying to reload Service Module SM1/0.
    Router#                           
    [Resuming connection 1 to 192.168.75.50 ... ]

    Time-out from RBIP response wait loop

     Serial ATA Port 0 : Hitachi HTE545050B9A300                
     Serial ATA Port 1 : Hitachi HTE545050B9A300                
    DDR Memory 4096 MB detected
    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz
    BIOS SM 3.52.6,  BIOS Build date: 08/03/2010
    Intel(R) Core(TM)2 Duo CPU     L9400  @ 1.86GHz
    BIOS SM 3.52.6,  BIOS Build date: 08/03/2010
    System now booting...
     
    Please wait... 
    Please press P to select Primary Boot Loader ...  
              or S to select Secondary Boot Loader ...  
              or wait to boot from default configuration ...  
    .......................................................................................................
    SRE module get located and run....  
    Now booting from secondary boot loader....  

    Authenticating boot loader....  

    Secondary Boot Loader authenticated - booting....  
     
    Please enter '***' to change boot configuration:
    Detect and Initialze network device

    Backup current platform configurations....
    SRE step 1 - SM registration...
    *Sep  9 17:01:54.255: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request
    Time-out from RBIP response wait loop
    *Sep  9 17:02:14.067: %SM_INSTALL-6-INST_RBIP: SM1/0 received msg: RBIP Registration Request

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Radhika Miriyala on 20-11-2010 01:33:41 AM
    Scott,

    This seems to be an issue with the Config for the MGF on the IOS side.
    Can you please give the output of the cli ¿show running-config¿ from the router ?

    Thanks,

    Radhika

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:41 AM
    Router#show config
    Using 1900 out of 262136 bytes
    !
    ! Last configuration change at 21:06:21 UTC Wed Sep 8 2010
    !
    version 15.0
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    !
    !
    memory-size iomem 20
    !
    no ipv6 cef
    ip source-route
    ip cef   
    !
    !
    !
    !
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    license udi pid CISCO2911/K9 sn FTX1429A35B
    hw-module sm 1
    !
    !
    !
    vtp version 2
    !
    redundancy
    !
    !
    !
    !
    !        
    !
    !
    !
    !
    interface GigabitEthernet0/0
     ip address 10.11.16.99 255.255.240.0
     ip nat outside
     ip virtual-reassembly
     duplex auto
     speed auto
     !
    !
    interface GigabitEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
     !
    !
    interface GigabitEthernet0/2
     no ip address
     shutdown
     duplex auto
     speed auto
     !
    !
    interface FastEthernet0/3/0
     !
    !
    interface FastEthernet0/3/1
     !
    !
    interface FastEthernet0/3/2
     !
    !
    interface FastEthernet0/3/3
     !
    !
    interface FastEthernet0/3/4
     !
    !
    interface FastEthernet0/3/5
     !
    !
    interface FastEthernet0/3/6
     !       
    !
    interface FastEthernet0/3/7
     !
    !
    interface FastEthernet0/3/8
     !
    !
    interface SM1/0
     ip address 192.168.75.50 255.255.255.0
     ip nat inside
     ip virtual-reassembly
     service-module ip address 192.168.75.51 255.255.255.0
     !Application: FNDN Running on SM
     service-module ip default-gateway 192.168.75.50
     !
    !
    interface SM1/1
     no ip address
     !
    !
    interface Cellular0/1/0
     no ip address
     encapsulation ppp
     !
    !
    interface Vlan1
     no ip address
     !
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    ip route 0.0.0.0 0.0.0.0 10.11.16.1
    !
    !
    !
    !
    !
    !
    !
    control-plane
     !
    !
    !        
    line con 0
    line aux 0
    line 0/1/0
     no exec
     speed 144000
    line 67
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
     flowcontrol software
    line vty 0 4
     login
    !
    scheduler allocate 20000 1000
    end

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Radhika Miriyala on 20-11-2010 01:33:41 AM
    Scott,

    From your config below you have not configured the IP address of the MGF interface. The ip address you configured is used by the console manager not hypervisor. You configure the MGF under the ¿interface  sm 1/0¿ in your case.



    The config would look like:

    interface SM1/0

    ip address 10.10.50.1 255.255.255.0

    service-module ip address 10.10.50.2 255.255.255.0

    !Application: SRE-V Running on SMV

    service-module ip default-gateway 10.10.50.1

    service-module mgf ip address 10.10.30.8 255.255.255.0

    service-module mgf ip default-gateway 10.10.30.1

    !        

    interface SM1/1

    description Internal switch interface connected to Service Module

    switchport mode trunk

    !        

    !        

    interface Vlan1

    ip address 10.10.30.1 255.255.255.0





    Thanks,

    Radhika

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:41 AM
    The MGF command seems unavailable. The "switchport mode trunk" on the SM1/1 also seems to be unavailable. I am running the bete IOS for the 2911.
     
     
     
    Router#confi t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Router(config)#int sm 1/0
    Router(config-if)#ser
    Router(config-if)#service-mod
    Router(config-if)#service-module mgf ip address 192.168.75.55 255.255.255.0
                                     ^
    % Invalid input detected at '^' marker.
    Router(config-if)#service-module ?
      ip  Service module ip configuration
    Router(config-if)#service-module
    Router#show ver
    Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Experimental Version 15.1(20100818:162633) [ssamant-t_base_1_0818 134]
    Copyright (c) 1986-2010 by Cisco Systems, Inc.
    Compiled Thu 19-Aug-10 00:49 by ssamant
    ROM: System Bootstrap, Version 15.0(1r)M6, RELEASE SOFTWARE (fc1)
    Router uptime is 31 minutes
    System returned to ROM by reload at 18:26:49 UTC Thu Sep 9 2010
    System image file is "flash0:/c2900-universalk9-beta.bin"
    Last reload type: Normal Reload
    Last reload reason: Reload Command
     
    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.
             
    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
    If you require further assistance please contact us by sending email to
    export@cisco.com.
    Cisco CISCO2911/K9 (revision 1.0) with 433152K/91136K bytes of memory.
    Processor board ID FTX1429A35B
    9 FastEthernet interfaces
    3 Gigabit Ethernet interfaces
    2 terminal lines
    1 Virtual Private Network (VPN) Module
    1 Cellular interface
    1 Services Module (SM) with Services Ready Engine (SRE)
       Cisco SRE-V Software 1.0.0.19 in slot 1
    DRAM configuration is 64 bits wide with parity enabled.
    255K bytes of non-volatile configuration memory.
    254464K bytes of ATA System CompactFlash 0 (Read/Write)

    License Info:
    License UDI:
    -------------------------------------------------
    Device#   PID                   SN
    -------------------------------------------------
    *0        CISCO2911/K9          FTX1429A35B    
     
    Technology Package License Information for Module:'c2900'
    ----------------------------------------------------------------
    Technology    Technology-package          Technology-package
                  Current       Type          Next reboot 
    -----------------------------------------------------------------
    ipbase        ipbasek9      Permanent     ipbasek9
    security      securityk9    Permanent     securityk9
    uc            None          None          None
    data          None          None          None
    Configuration register is 0x2102
    Router#
     
    Scott,

    From your config below you have not configured the IP address of the MGF interface. The ip address you configured is used by the console manager not hypervisor. You configure the MGF under the ¿interface sm 1/0¿ in your case.



    The config would look like:

    interface SM1/0

    ip address 10.10.50.1 255.255.255.0

    service-module ip address 10.10.50.2 255.255.255.0

    !Application: SRE-V Running on SMV

    service-module ip default-gateway 10.10.50.1

    service-module mgf ip address 10.10.30.8 255.255.255.0

    service-module mgf ip default-gateway 10.10.30.1

    !

    interface SM1/1

    description Internal switch interface connected to Service Module

    switchport mode trunk

    !

    !

    interface Vlan1

    ip address 10.10.30.1 255.255.255.0

    !



    Thanks,

    Radhika

    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Thursday, September 09, 2010 10:50 AM
    To: cdicuser@developer.cisco.com
    Subject: New Message from SCOTT PITTS in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S



    SCOTT PITTS has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    Router#show config
    Using 1900 out of 262136 bytes
    !
    ! Last configuration change at 21:06:21 UTC Wed Sep 8 2010
    !
    version 15.0
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    !
    !
    memory-size iomem 20
    !
    no ipv6 cef
    ip source-route
    ip cef
    !
    !
    !
    !
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    license udi pid CISCO2911/K9 sn FTX1429A35B
    hw-module sm 1
    !
    !
    !
    vtp version 2
    !
    redundancy
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    ip address 10.11.16.99 255.255.240.0
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    !
    !
    interface GigabitEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    !
    interface GigabitEthernet0/2
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    !
    interface FastEthernet0/3/0
    !
    !
    interface FastEthernet0/3/1
    !
    !
    interface FastEthernet0/3/2
    !
    !
    interface FastEthernet0/3/3
    !
    !
    interface FastEthernet0/3/4
    !
    !
    interface FastEthernet0/3/5
    !
    !
    interface FastEthernet0/3/6
    !
    !
    interface FastEthernet0/3/7
    !
    !
    interface FastEthernet0/3/8
    !
    !
    interface SM1/0
    ip address 192.168.75.50 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    service-module ip address 192.168.75.51 255.255.255.0
    !Application: FNDN Running on SM
    service-module ip default-gateway 192.168.75.50
    !
    !
    interface SM1/1
    no ip address
    !
    !
    interface Cellular0/1/0
    no ip address
    encapsulation ppp
    !
    !
    interface Vlan1
    no ip address
    !
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    ip route 0.0.0.0 0.0.0.0 10.11.16.1
    !
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    line con 0
    line aux 0
    line 0/1/0
    no exec
    speed 144000
    line 67
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    flowcontrol software
    line vty 0 4
    login
    !
    scheduler allocate 20000 1000
    end
    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2519437>
    or simply reply to this email.


    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Anurag Gurtu on 20-11-2010 01:33:41 AM
    Can you please type show version on your router prompt. You should see something like IOS 29¿¿ 819.

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Radhika Miriyala on 20-11-2010 01:33:41 AM
    Scott,

    Do you happen to have any other hwic  modules in the router?

    Thanks,

    Radhika

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:41 AM
    I had the show ver attached in my last post. The router has HWIC-3G-CDMA, HWIC-9ESW, and the SM-SRE-900 installed.
     
     
     
     

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Radhika Miriyala on 20-11-2010 01:33:42 AM
    Scott,

    The new configuration that is mentioned in the user guide and the one I suggested would not work with HWIC-9ESW.  You will have to use a different configuration



    This is what you would need to do:

    From the router configure the¿ interface sm 1/1 ¿



    The config would look like
    interface sm 1/1

    ip address 192.168.100.10 255.255.255.0

    service-module ip address 192.168.100.11 255.255.255.0

    no shut



    after your configure this on the IOS you will need to do the following



    1)      session into the SM ¿service-module sm 1/0 session¿

    2)      Reload the SM using the cli ¿reload¿

    3)      Once the system is back up please configure the default-gateway for the hypervisor using the cli ¿ hypervisor set ip default-gateway 192.168.100.10¿





    After this you should be able to connect to the hypervisor using the the ip address ¿192.168.100.11¿ in this example.





    Let me know if you have any questions.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Thursday, September 09, 2010 12:32 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from SCOTT PITTS in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S



    SCOTT PITTS has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    I had the show ver attached in my last post. The router has HWIC-3G-CDMA, HWIC-9ESW, and the SM-SRE-900 installed.




    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2519645>
    or simply reply to this email.

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:42 AM
    Scott,

    The new configuration that is mentioned in the user guide and the one I suggested would not work with HWIC-9ESW. You will have to use a different configuration



     
    Why the difference? Is it because the 9ESW connects to the MGF as well? Is it going to be possible to use the MGF to connect the 9ESW and VMWare like you can on the SM Switch module or is there a limitation on the 9ESW? There seems to ba a lot of limitations with the 9ESW that I am finding out after the purchase like port security. I am certain that this is the wrong forum for that though.
     
    It seems that I finally have ESXi running.

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Radhika Miriyala on 20-11-2010 01:33:42 AM
    Scott,

    Glad you have the ESXI working.

    Thanks,

    Radhika

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:43 AM


    Scott,

    The new configuration that is mentioned in the user guide and the one I suggested would not work with HWIC-9ESW. You will have to use a different configuration







    Does using the HWIC-9ESW remove my ability to trunk to VMWare via the MGF (SM1/1)? Can I connect the HWIC-9ESW to VMWare? What are my limitation when I use the HWIC-9ESW and is better support being worked on?
     

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:44 AM
    Can I trunk to the MGF with the HWIC-9ESW installed? I would still like to know the limitations around the HWIC-9ESW and the SM-SRE-900-K9 running ESXi.
     




    Scott,

    The new configuration that is mentioned in the user guide and the one I suggested would not work with HWIC-9ESW. You will have to use a different configuration









    Does using the HWIC-9ESW remove my ability to trunk to VMWare via the MGF (SM1/1)? Can I connect the HWIC-9ESW to VMWare? What are my limitation when I use the HWIC-9ESW and is better support being worked on?
     


    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Radhika Miriyala on 20-11-2010 01:33:44 AM
    Scott,

    The HWIC-9ESW is a  older generation ether switch and there are some limitations with how it will work with a SRE-SM-900.  You can still use them together using a  different method  either HIMI or VLAN connect.  The way to configure this is not in our beta user document. I am trying to get the write documentation that will help you with configuring the HWIC-9ESW with the SM-SRE-900 module.  I will forward the document as soon as I can.

    I also wanted to let you know that there is a newer generation  EHWIC that will enable to use the newer features.

    Thanks,

    Radhika

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:50 AM
    I mis-spoke as these are HWIC-D-9ESW & HWIC-D-9ESW-POE, which I believe are the current models as I can not find any documentation on an EHWIC switch. Maybe there is a new module that is comming out that has not been relased yet with the EHWIC designation.
     
    Scott,

    The HWIC-9ESW is a older generation ether switch and there are some limitations with how it will work with a SRE-SM-900. You can still use them together using a different method either HIMI or VLAN connect. The way to configure this is not in our beta user document. I am trying to get the write documentation that will help you with configuring the HWIC-9ESW with the SM-SRE-900 module. I will forward the document as soon as I can.



    I also wanted to let you know that there is a newer generation EHWIC that will enable to use the newer features.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Tuesday, September 14, 2010 12:51 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from SCOTT PITTS in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S



    SCOTT PITTS has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    Can I trunk to the MGF with the HWIC-9ESW installed? I would still like to know the limitations around the HWIC-9ESW and the SM-SRE-900-K9 running ESXi.






    Scott,

    The new configuration that is mentioned in the user guide and the one I suggested would not work with HWIC-9ESW. You will have to use a different configuration









    Does using the HWIC-9ESW remove my ability to trunk to VMWare via the MGF (SM1/1)? Can I connect the HWIC-9ESW to VMWare? What are my limitation when I use the HWIC-9ESW and is better support being worked on?



    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2537388>
    or simply reply to this email.


    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: SCOTT PITTS on 20-11-2010 01:33:50 AM
    I did finally find the EHWIC-D-8ESG-P. This works better with the SRE and ESXi correct?
     
    I have started the RMA for 9ESW for this EHWIC model which is actually cheaper than the 9ESW.
     
    Thanks for the assistance and I would still like to have the configuration information when you find it for both ethernet modules.
     
     

    Subject: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S
    Replied by: Radhika Miriyala on 20-11-2010 01:33:50 AM
    Scott,

    EHWIC-D-8ESG will work with the SRE using the MGF interface. Please check the data sheet to make sure it satisfies your other needs also.



    Regarding the docs for using the HWIC-D-9ESW with the SRE you have to you a HIMI or a VLAN connect to do it. Here is a link to the document that talks about configuring HIMI and VLAN connect.



    http://www.cisco.com/en/US/docs/routers/access/interfaces/software/feature/guide/HIMI_2900_3900.html#wp1078634



    Please let us know if you need more information.



    Thanks,

    Radhika



    From: Cisco Developer Community Forums [mailto:cdicuser@developer.cisco.com]
    Sent: Wednesday, September 15, 2010 12:57 PM
    To: cdicuser@developer.cisco.com
    Subject: New Message from SCOTT PITTS in Service Ready Engine Virtualization - SRE-V Beta Testing: RE: New Message from SCOTT PITTS in Service Ready Engine Virtualization - S



    SCOTT PITTS has created a new message in the forum "SRE-V Beta Testing":
    --------------------------------------------------------------
    I did finally find the EHWIC-D-8ESG-P. This works better with the SRE and ESXi correct?

    I have started the RMA for 9ESW for this EHWIC model which is actually cheaper than the 9ESW.

    Thanks for the assistance and I would still like to have the configuration information when you find it for both ethernet modules.


    --
    To respond to this post, please click the following link:
    <http://developer.cisco.com/group/srev/forums/-/message_boards/message/2541149>
    or simply reply to this email.