AXL Code -1

Version 1
    This document was generated from CDN thread

    Created by: vimod shankar on 19-10-2010 11:44:10 AM
    Hi,
     
        We are using axl to add a new phone to the CUCM ( 8.0) when we execute the web service call, we are getting a response "<?xml version='1.0' encoding='UTF-8'?>
          <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
                 <soapenv:Body><soapenv:Fault>
                      <faultcode>soapenv:Server</faultcode>
                      <faultstring></faultstring>
                      <detail>
                          <axlError>
                               <axlcode>-1</axlcode>
                               <axlmessage></axlmessage>
                               <request>addPhone</request>
                          </axlError>
                      </detail>
            </soapenv:Fault>
          </soapenv:Body>
       </soapenv:Envelope>"
     
    Can you please provide more details on the "axlCode = -1" as we are not getting any details from the error message. 
     
    Thanks and Regards,
    Vimod
     
     

    Subject: RE: AXL Code -1
    Replied by: David Staudt on 19-10-2010 04:06:07 PM
    You may be able to get some more information about the problem by inspecting the AXL service logs.  I would suggest increasing the AXL service logs (via the UCM Serviceability pages) to detailed/debug level, and checking the resulting logs via the Real Time Management Tool plugin.
     
    If you still can't spot anything feel free to attach your request/response and logs here.

    Subject: RE: AXL Code -1
    Replied by: vimod shankar on 20-10-2010 06:13:37 PM
    You may be able to get some more information about the problem by inspecting the AXL service logs.  I would suggest increasing the AXL service logs (via the UCM Serviceability pages) to detailed/debug level, and checking the resulting logs via the Real Time Management Tool plugin.
     
    If you still can't spot anything feel free to attach your request/response and logs here.


     
     
     
     
    Hi David,
     
    Please find attached the request and the response files for the service call. Also though we know how to make changes to the trace settings in serviceability, we are not sure as to where the log files can be found. Can you please provide us with the information as to where we can find the log files.
     
    Thanks in advance,
    Vimod

    Subject: RE: AXL Code -1
    Replied by: David Staudt on 20-10-2010 07:25:15 PM
    It looks like at least the following fields are missing:
     

                <product>?</product>
                <class>?</class>
                <protocol>?</protocol>
                <protocolSide>User</protocolSide>

     
    Please check the addPhone schema definition and include any required fields.

    Subject: RE: AXL Code -1
    Replied by: Hossam Yahia on 25-02-2012 08:58:17 AM
    Please help me with this.

    ==========================================Request===================================================

    POST /axl/ HTTP/1.0
    Host:localhost:8443
    Authorization: Basic YWRtaW46Y2NpZXZvaWNl
    Accept: text/*
    Content-type: text/xml
    SOAPAction: "CUCMB ver=8.0"
    Content-length: 1098


    <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
       <SOAP-ENV:Body>
          <axl:addUserPhoneAssociation sequence="1234" xmlns:axl="http://www.cisco.com/AXL/API/8.0">
             <userPhoneAssociation>
                <userId>ABCXp17</userId>
                <password>0188083986</password>
                <pin>123</pin>
                <lastName>HossamXB18</lastName>
                <middleName>HossamX8</middleName>
                <firstName>HossamX1</firstName>
                <productType>Cisco 7940</productType>
                <name>SEPABABA0993335</name>
                <dnCssName>CSS-B</dnCssName>
                <phoneCssName>CSS-U1</phoneCssName>
                <e164Mask>20987772</e164Mask>
                <extension>3377</extension>
                <routePartitionName>P12</routePartitionName>
                <voiceMailProfileName/>
                <enableExtensionMobility>true</enableExtensionMobility>
             </userPhoneAssociation>
          </axl:addUserPhoneAssociation>
       </SOAP-ENV:Body>
    </SOAP-ENV:Envelope>


    ==========================================Response===================================================

    <?xml version='1.0' encoding='UTF-8'?>
    <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
    <soapenv:Body>
      <soapenv:Fault>
       <faultcode>SOAP-ENV:Server</faultcode>
       <faultstring>Error getting the password.</faultstring>
       <detail>
        <axlError>
         <axlcode>5003</axlcode>
         <axlmessage>Error getting the password.</axlmessage>
         <request>addUserPhoneAssociation</request>
        </axlError>
       </detail>
      </soapenv:Fault>
    </soapenv:Body>
    </soapenv:Envelope>