Getting IMS_Error while doing PIN Change

Version 1
    This document was generated from CDN thread

    Created by: Viki Rai on 08-10-2010 07:33:22 AM
    Hi All,
     
    I am using 7.1.3-CUPI-WADL version.

    Ques : 1
    When I do a PUT
    request to change PIN using the following snippet, Im getting IMS_ERROR (Invalid Credential)
     
    Input XML:
    PUT  https://<server>/vmrest/users/<userobjectid>/credential/pin
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <Credential>
    <CredentialType>4</CredentialType>
    <Credentials>Welcome1</Credentials>
    <Alias>xxxx</Alias>
    <EncryptionType>3</EncryptionType>
    </Credential>
    Error Response:

    <?xml version="1.0" encoding="UTF-8"
    standalone="yes"?>
    <ErrorDetails><errors>
    <code>IMS_ERROR</code>
    <message>Invalid
    Credential</message></errors>
    </ErrorDetails>
     
    What does IMS_ERROR means?
     
    Plss guide me to get the issue resolve.

    Subject: RE: Getting IMS_Error while doing PIN Change
    Replied by: PATRICK NOWICKI on 10-10-2010 03:14:05 AM
    Hi Viki,
    Are you intending to encrypt your PIN with an IMS type Hash? I am thinking that your Welcome1 PIN is not a valid Hashed PIN. If you dont care about encrypting the PIN on the way to Unity, you can leave out the encryption type all together or make it a "5" for NONE. you would then need to make the credentials field a valid numeric PIN, i.e. 12345, rather than an alpha password. Be aware that the PIN must conform to the authentication rules in Unity, i.e. trivial PIN's and minimum PIN length (I find 112233 works well as a default).
    If I am off base here, let me know. Hope that helps!
    -Patrick