Error: Permission denied, -7ff5ffba

Version 1
    This document was generated from CDN thread

    Created by: Darren Chen Loong Heng on 14-09-2010 08:52:08 AM
    Hi Guys,
     
    I have sent up the CiscoIPServices Server using the guide below:
     
    Cisco Unified IP Phone Services Application Development Notes, Release 7.1(2)
     
    While it seems to be working great and my IP Phones are able to subscribe to them and pull data such as stock information from the internet... I am still having problems with some of the scripts. My current problem is with "stockchart2.asp".
     
    Everytime i run it, I get the error: "Error: Permission denied, -7ff5ffba". Going through the ASP script, line by line, I find that the problem is with this line: "var Inet1 = new ActiveXObject("CiscoURLProxy.URLGrabber");". If I comment it out, the script runs but obvisously I need that line for the script to give me the results I need.
     
    I have restarted IIS Admin, restarted the server, given domain admin access to the componet: CiscoURLProxy, given all access for CiscoIPServices in IIS, and given full access to the CiscoIPServices folder...but I still get the above error.
     
    Did anyone else get this problem and is there a resolution?
     
    Thanks in advance!
    Darren

    Subject: RE: Error: Permission denied, -7ff5ffba
    Replied by: Darren Chen Loong Heng on 14-09-2010 09:27:37 AM
    Hi Guys,
     
    I have sent up the CiscoIPServices Server using the guide below:
     
    Cisco Unified IP Phone Services Application Development Notes, Release 7.1(2)
     
    While it seems to be working great and my IP Phones are able to subscribe to them and pull data such as stock information from the internet... I am still having problems with some of the scripts. My current problem is with "stockchart2.asp".
     
    Everytime i run it, I get the error: "Error: Permission denied, -7ff5ffba". Going through the ASP script, line by line, I find that the problem is with this line: "var Inet1 = new ActiveXObject("CiscoURLProxy.URLGrabber");". If I comment it out, the script runs but obvisously I need that line for the script to give me the results I need.
     
    I have restarted IIS Admin, restarted the server, given domain admin access to the componet: CiscoURLProxy, given all access for CiscoIPServices in IIS, and given full access to the CiscoIPServices folder...but I still get the above error.
     
    Did anyone else get this problem and is there a resolution?
     
    Thanks in advance!
    Darren


    Hey Guys, for those of you with this problem. You may have to change your Anonymous domain account with administrator access. I changed that and it now works!
     
    Cheers
    Darren Heng