doAuthenticateUser

Version 1
    This document was generated from CDN thread

    Created by: Chikeobi Njaka on 20-10-2009 08:25:37 PM
    Hi,
    My application is using a proxy account to make sure users are authenticated against call manager. To do this, I make a call to the AXL doAuthenticateUser command. The problem is that no matter what PIN I use (I an using the PIN field), it always returns "true".
    Any ideas?

    Subject: RE: doAuthenticateUser
    Replied by: Chikeobi Njaka on 20-10-2009 10:23:00 PM
    Very odd
     
    - Can you provide the XML request and response?
    - Is your UCM configured for LDAP or Active Directory integration for user authentication?

    [1] Here are the request and response:
    <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"> <SOAP-ENV:Body> <doAuthenticateUser sequence="1210779467"><userid>mpeverill</userid><pin>12345</pin></doAuthenticateUser></SOAP-ENV:Body> </SOAP-ENV:Envelope>
    <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Header/><SOAP-ENV:Body><axl:doAuthenticateUserResponse xmlns:axl="http://www.cisco.com/AXL/API/6.0" xmlns:xsi="http://www.cisco.com/AXL/API/6.0" sequence="1210779467"><return><userAuthenticated>true</userAuthenticated><code>0</code></return></axl:doAuthenticateUserResponse></SOAP-ENV:Body></SOAP-ENV:Envelope>
    [2] LDAP

    Subject: RE: doAuthenticateUser
    Replied by: David Staudt on 20-10-2009 10:14:14 PM
    Very odd
     
    - Can you provide the XML request and response?
    - Is your UCM configured for LDAP or Active Directory integration for user authentication?

    Subject: RE: doAuthenticateUser
    Replied by: David Staudt on 20-10-2009 11:43:04 PM
    Thanks...the request/response look ok.  Some further questions:
     
    - Complete UCM version
    - Are both LDAP sync and LDAP authentication enabled?
    - Does PIN authentication work correctly in general - i.e. for Extension Mobility login?
    - Does the user Credential Policy Default for PIN have any special/non-default settings?