Search Device Class SIPTrunk

Version 1
    This document was generated from CDN thread

    Created by: Phillip McAvoy on 11-09-2009 07:58:41 AM
    Hi,
     
    I am having a little play with getting various device info via AXL on CUCM 6.1(x) and it is all working fine so far, but the only one that is not working for me is the search device class 'SIPTrunk' as I always get no such class coming back.  Is this a mistake in the Documentation 6.1(x) XML Developer Guide?
     

    <?xml version="1.0" encoding="UTF-8"?>
    <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <soapenv:Body>
        <ns1:SelectCmDevice soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:ns1="http://schemas.cisco.com/ast/soap/">
          <StateInfo xsi:type="xsd:string"/>
          <CmSelectionCriteria xsi:type="ns1:CmSelectionCriteria">
            <MaxReturnedDevices xsi:type="xsd:unsignedInt">200</MaxReturnedDevices>
            <Class xsi:type="xsd:string">SIPTrunk</Class>
            <Model xsi:type="xsd:unsignedInt">255</Model>
            <Status xsi:type="xsd:string">Any</Status>
            <NodeName xsi:type="xsd:string"/>
            <SelectBy xsi:type="xsd:string">Name</SelectBy>
            <SelectItems soapenc:arrayType="ns1:SelectItem[3]" xsi:type="soapenc:Array" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/">
              <item xsi:type="ns1:SelectItem">
                <Item xsi:type="xsd:string">SE_GOT_CUBE_01</Item>
              </item>
              <item xsi:type="ns1:SelectItem">
                <Item xsi:type="xsd:string">SE_GOT_MSUM</Item>
              </item>
              <item xsi:type="ns1:SelectItem">
                <Item xsi:type="xsd:string">AU_CHUL_ICT</Item>
              </item>
            </SelectItems>
            &quot;
          </CmSelectionCriteria>
        </ns1:SelectCmDevice>
      </soapenv:Body>
    </soapenv:Envelope>
     
    What I am after is just picking out the SIP Trunks without having to define the name of the trunk.
     
    Best regards,
    Phillip

    Subject: RE: Search Device Class SIPTrunk
    Replied by: David Staudt on 11-09-2009 06:33:43 PM
    Has the SIP trunk been up and running since the UCM was restarted?  If you just configure it, but it never connects then there will be no entry in the RIS tracking tables.

    Subject: RE: Search Device Class SIPTrunk
    Replied by: Phillip McAvoy on 14-09-2009 05:38:20 AM
    Yes the SIP Trunks have been operational for a long time, this is more to do with the Device Class definition and it seems what is mentioned in the 6.1 XML guide migth not be actually true.