ip phone speaker not activating for RTPMRx request

Version 1

    Subject: RE: ip phone speaker not activating for RTPMRx request
    Replied by: David Staudt on 29-05-2009 07:39:51 PM
    Couple of questions:
     
    - Are all phones on the latest available firmware release?  or at least the same release?
    - Is this happening only on 7940 phones? on all of the 7940s you have, or just  2 of them?
     
     
     
    This document was generated from CDN thread

    Created by: Chris Manuh on 29-05-2009 07:04:31 PM
    I'm pushing a CiscoIPPhoneExecute object to a bunch of ip phones with RTPMRx url for them to start receiving a multicast stream. When this request is delivered, all the microphone on the ip phones are muted and the speakers are activated, except for two particular phones: 7940. on this particular phone, the microphone is muted but the speaker doesn't activate like the rest of the phones. the multicast indicator icons shows properly, but i can only hear the audio after manually pressing the speaker button.  Is this a certain feature of the phone or is it a defect and if so how do i fix it?
     
    Thanks
    Chris

    Subject: RE: ip phone speaker not activating for RTPMRx request
    Replied by: Chris Manuh on 04-06-2009 02:12:07 PM
    David, thanks for the response.
    We've found out when this behavior occurs. If you lift the handset, you'll get a dial tone and the softkey on the phone will say end call. if you press this softkey without putting the handset back, the dial tone goes away but you'll see a little icon at the bottom left corner of the screen showing that the handset is off hook. in this state, if you send an RTPRx request to the phone, the speaker will not go off.

    Subject: RE: ip phone speaker not activating for RTPMRx request
    Replied by: David Staudt on 04-06-2009 03:14:41 PM
    Interesting...does the audio come through the handset at that point?  Can you reproduce this behaviour on the other phone models?