AXL Soap Client with CCM 4.2

Version 1
    This document was generated from CDN thread

    Created by: Carlos Plaza Gomez on 21-10-2008 11:32:58 AM
    Hi,
    I have an application working with CCM 5.1, but now I have to develop it for CCM 4.2, so I'm trying to create a new client using the .NET's wsdl tool but this time I'm getting this error:

    C:\temp>wsdl.exe AXLAPI.wsdl AXLSoap.xsd

    Microsoft (R) Web Services Description Language Utility
    [url=http://Microsoft (R) .NET Framework, Version 2.0.50727.42]http://Microsoft (R) .NET Framework, Version 2.0.50727.42
    Copyright (C) Microsoft Corporation. All rights reserved.
    Error: Unable to import binding 'AXLAPIBinding' from namespace 'http://www.cisco.com/AXLAPIService/'.
    - Unable to import operation 'addPhone'.
    - These members may not be derived.

    Could anyone tell me what the **** I'm doing wrong?
    I suppose that something is wrong either in the wsdl file or in the xsd files, but I can't find out what, so any possible solution will be appreciatted.

    Thanks in advanced.

    Subject: Re: AXL Soap Client with CCM 4.2
    Replied by: James Shepard on 22-10-2008 02:35:43 PM
    .

    Subject: Re: AXL Soap Client with CCM 4.2
    Replied by: Carlos Plaza Gomez on 23-10-2008 10:41:39 AM
    Hi Madhukar,
    First of all, thank you very much for responding so fast.

    As you can see in my first post, I follow the same steps that you do: copy the wdsl.exe, the xsd files and the wsdl file in the same folder, and then open a command window and execute 'wsdl.exe AXLAPI.wsdl AXLSoap.xsd', but I get the error I reported in my first post.

    I forgot to tell that I'm using the 4.2(1) version, which is composed by 5 files (AXLAPI.wsdl, axlsoap.xsd, axl.xsd, AXLEnums.xsd, axlmessage.xsd).

    But apparently there are some differences between both versions (4.2(1) & 4.2(3)), because I've tried your schema files and I get this error:


    -----
    C:\temp>wsdl.exe AXLAPI.wsdl axl.xsd

    Microsoft (R) Web Services Description Language Utility
    [url=http://Microsoft (R) .NET Framework, Version 2.0.50727.42]http://Microsoft (R) .NET Framework, Version 2.0.50727.42
    Copyright (C) Microsoft Corporation. All rights reserved.

    Schema validation error: Schema with targetNamespace='http://www.cisco.com/AXL/A
    PI/1.0' has invalid syntax. Multiple definition of element 'tunneledProtocol' ca
    uses the content model to become ambiguous. A content model must be formed such
    that during validation of an element information item sequence, the particle con
    tained directly, indirectly or implicitly therein with which to attempt to valid
    ate each item in the sequence in turn can be uniquely determined without examini
    ng the content or attributes of that item, and without any information about the
    items in the remainder of the sequence. Line 965, position 12.

    Schema validation error: Schema with targetNamespace='http://www.cisco.com/AXL/A
    PI/1.0' has invalid syntax. Multiple definition of element 'tunneledProtocol' ca
    uses the content model to become ambiguous. A content model must be formed such
    that during validation of an element information item sequence, the particle con
    tained directly, indirectly or implicitly therein with which to attempt to valid
    ate each item in the sequence in turn can be uniquely determined without examini
    ng the content or attributes of that item, and without any information about the
    items in the remainder of the sequence. Line 10485, position 12.

    Warning: Schema could not be validated. Class generation may fail or may produce
    incorrect results.
    Writing file 'C:\temp\AXLAPIService.cs'.

    -----

    However, the AXLAPIService.cs file is generated and I've tried it with my 4.2(1) CCM, but it doesn't work. I've attempted to modify a little bit that file (connection URL, etc) but eventually it doesn't work at all.

    I think I only can use 4.2(1) version files, so I would like to attach them to this post so you can test them as well but this forum doesn't allow me to attach any file, I don't know why, but I'm not able to send you anything. Perhaps you could get it from another source....

    Anyway I'll keep on trying and I'll send a mail to the addres you gave me.

    Thank you.