Python Perfmon Processor response at 0

Version 1
    This document was generated from CDN thread

    Created by: Leonard LECOUEY on 14-06-2010 01:07:24 PM
    Hello,
    I'm trying to get some informations from a Call Manager 7 using AXL. All is working well in python but I have an issue with the Processor information. When I check the Processor class in perfmon, the axl call only retrieve zero values:

    (0)%CPUTime:0
    (0)IOwaitPercentage:0
    (0)IdlePercentage:0
    (0)IrqPercentage:0
    (0)NicePercentage:0
    (0)SoftirqPercentage:0
    (0)SystemPercentage:0
    (0)UserPercentage:0
    (1)%CPUTime:0
    (1)IOwaitPercentage:0
    (1)IdlePercentage:0
    (1)IrqPercentage:0
    (1)NicePercentage:0
    (1)SoftirqPercentage:0
    (1)SystemPercentage:0
    (1)UserPercentage:0
    (_Total)%CPUTime:0
    (_Total)IOwaitPercentage:0
    (_Total)IdlePercentage:0
    (_Total)IrqPercentage:0
    (_Total)NicePercentage:0
    (_Total)SoftirqPercentage:0
    (_Total)SystemPercentage:0
    (_Total)UserPercentage:0

    But in RTMT, these values are not at 0 but have the correct information. So I'm looking how to get the correct value with tha AXL call in python?
    Regards

    Subject: RE: Python Perfmon Processor response at 0
    Replied by: Mohamed Nadjib HAMMOUDI on 16-05-2012 10:58:46 AM
    Hello,
    I have the same issue and i see that after two years no one answered this question :/ if you found an explanation please post it.

    Regards

    Subject: RE: Python Perfmon Processor response at 0
    Replied by: Mohamed Nadjib HAMMOUDI on 16-05-2012 11:26:47 AM
    Hello,

    Finally i found the explanation (it dosn't took me 2 years though lol). Percentage counters require two samples to determine the average between the samples, but you have to use the session-based Perfmon operation (perfmonCollectSessionData) with 4 sec minimum between the samples.

    Regards