addMGCPEndpoint Error 1213: Character to numeric conversion error

Version 1
    This document was generated from CDN thread

    Created by: Josh Stevens on 25-03-2010 05:51:46 PM
    Hi all,
     
    I'm trying to add an MGCP endpoint after successfully adding the gateway itself in a previous request.  This is the output I receive:
     
    <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><SOAP-ENV:Header/><SOAP-ENV:Body><SOAP-ENV:Fault><faultcode>SOAP-ENV:Client</faultcode><faultstring>Character to numeric conversion error</faultstring><detail><axl:Error xmlns:axl="http://www.cisco.com/AXL/API/6.1"><axl:code>-1213</axl:code><axl:message>Character to numeric conversion error</axl:message><request>addMGCPEndpoint</request></axl:Error></detail></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>
     
    Any help appreciated.
     
    Thanks,
     
    Josh

    Subject: RE: addMGCPEndpoint Error 1213: Character to numeric conversion error
    Replied by: Anitha V on 26-03-2010 05:17:39 AM
    Hi Josh,
     
    Could you please send the request which you are using, along with the detailed AXL logs?
     
    what is the exact callManager you are using?
     
    Regards,
    Anitha

    Subject: RE: addMGCPEndpoint Error 1213: Character to numeric conversion error
    Replied by: Josh Stevens on 26-03-2010 01:26:48 PM
    Hi Anitha,
     
    Thanks for the response...this is the request I am sending, and I'm using CCM 6.1.3.3206
     
    addMGCPEndpoint
    <domainName>FLSTAWP02VAR01</domainName>
    <unit>2</unit>
    <subunit>0</subunit>
    <endpoint index="0">
        <name>AALN/S2/SU0/0@FLSTAWP02VAR01</name>
        <description>postage meter</description>
        <product>Cisco MGCP FXS Port</product>
        <model>MGCP Station</model>
        <class>Gateway</class>
        <protocol>Analog Access</protocol>
        <callingSearchSpaceName>wd1441_outbound_css</callingSearchSpaceName>
        <devicePoolName>DP_WD1441</devicePoolName>
        <locationName>LOC_WD1441</locationName>
        <packetCaptureMode>None</packetCaptureMode>
    </endpoint>
     
    I'm attaching the log which shows the error.  Thanks for taking a look.
     
    Cheers,
     
    Josh

    Subject: RE: addMGCPEndpoint Error 1213: Character to numeric conversion error
    Replied by: Josh Stevens on 26-03-2010 01:37:02 PM
    Actually, I saw one error *I think*, and changed my query to the following:
     
    <domainName>FLSTAWP02VAR01</domainName>
    <unit index="2"></unit>
    <subunit index="0"></subunit>

    <endpoint index="0">
        <name>AALN/S2/SU0/0@FLSTAWP02VAR01</name>
        <description>postage meter 9048083764</description>
        <product>Cisco MGCP FXS Port</product>
        <model>MGCP Station</model>
        <class>Gateway</class>
        <protocol>Analog Access</protocol>
        <callingSearchSpaceName>wd1441_outbound_css</callingSearchSpaceName>
        <devicePoolName>DP_WD1441</devicePoolName>
        <locationName>LOC_WD1441</locationName>
        <packetCaptureMode>None</packetCaptureMode>
    </endpoint>
     
    basically changing the lines in red... now the query completes with the output I'm attaching, but logging in to ccm does not show the port configured.  Upon clicking on the port, I get the following screen in CCM.  Strange.