Tcl script is working but the call didt route the hunt group

Version 1
    This document was generated from CDN thread

    Created by: javeen shanavas on 27-02-2010 01:48:03 PM
    Hi Experts,
     
    I am having  a problem with my TCL: 
    Every thing was working fine but suddenly a problem came up:
    when a caller dials the company number a greeting message is played, but when he dials the extension, the routers does not recognize the entered digits, and this message played "the destination you called is unreachable please re-enter the number you are calling"  
     Any idea to solve this probelm???
     
    cofig mention below
     
     

    Building configuration...
     
    Current configuration : 19337 bytes
    !
    ! Last configuration change at 07:10:45 UTC Sun Jan 31 2010 by nascom
    ! NVRAM config last updated at 07:02:36 UTC Sun Jan 31 2010 by nascom
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Nascom_Lease
    !
    boot-start-marker
    boot-end-marker
    !
    ! card type command needed for slot/vwic-slot 0/1
    logging buffered 51200 warnings
    enable password 7 03175A1E0206751D
    !
    no aaa new-model
    !
    resource policy
    !
    clock calendar-valid
    !
    !
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 172.16.1.201
    ip dhcp excluded-address 172.16.1.225
    ip dhcp excluded-address 172.16.1.240 172.16.1.245
    ip dhcp excluded-address 192.168.2.1
    ip dhcp excluded-address 192.168.1.100
    !
    ip dhcp pool VOICE
       network 192.168.2.0 255.255.255.0
       default-router 192.168.2.1
       option 150 ip 192.168.2.1
       domain-name nascom.com.sa
       dns-server 172.16.1.1 212.102.0.10
    !
    ip dhcp pool voice
    !
    !
    no ip domain lookup
    ip domain name nascom.com.sa
    !
    !
    voice-card 0
     no dspfarm
    !
    !
    !
    voice service voip
     allow-connections h323 to h323
     allow-connections h323 to sip
     allow-connections sip to h323
     allow-connections sip to sip
     h323
      call start slow
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice register global
     max-dn 48
     max-pool 12
    !
    !
    voice translation-rule 2
     rule 1 /^7...\(5555\)/ /90044232141\1/
    !
    voice translation-rule 3
     rule 1 /^7...\(5555\)/ /\1/
    !
    !
    !
    application
     service aa flash:/bacdprompts/app-b-acd-aa-2.1.0.0.tcl
     !
     service cme-aaf flash:app-b-acd-aa-2.1.2.2.tcl
      paramspace english index 0
      param second-greeting-time 30
      paramspace english language en
      param max-time-vm-retry 1
      param voice-mail 511
      param max-time-call-retry 60
      param max-extension-length 3
      param aa-pilot 594
      param number-of-hunt-grps 8
      paramspace english location flash:/phone/
      param dial-by-extension-option 9
      param handoff-string cme-aaf
      param call-retry-timer 20
      paramspace english prefix en
      param service-name acdf
     !
     service cme-aaf2 flash:app-b-acd-aa-2.1.2.2.tcl
      paramspace english index 0
      param max-extension-length 3
      param aa-pilot 596
      paramspace english language en
      param second-greeting-time 30
      param call-retry-timer 20
      param max-time-call-retry 60
      param voice-mail 511
      param service-name acdf2
      paramspace english location flash:
      param number-of-hunt-grps 8
      param dial-by-extension-option 9
      param handoff-string cme-aaf2
      paramspace english prefix en
      param max-time-vm-retry 1
     !
     service aa12 service
     !
     service acdf2 flash:app-b-acd-2.1.2.2.tcl
      param aa-hunt8 511
      param queue-cme-debugs 1
      param aa-hunt4 561
      param aa-hunt5 541
      param aa-hunt1 596
      param aa-hunt2 511
      param aa-hunt6 536
      param number-of-hunt-grps 8
      param aa-hunt7 541
      param queue-len 30
      param aa-hunt3 570
     !
     service TOLL flash:app-b-acd-2.1.2.2.tcl
      param aa-hunt1 511
      param number-of-hunt-grps 8
      param queue-len 30
      param queue-cme-debugs 1
     !
     service queue flash:/bacdprompts/app-b-acd-2.1.0.0.tcl
     !
     service acdf flash:app-b-acd-2.1.2.2.tcl
      param aa-hunt2 511
      param number-of-hunt-grps 8
      param aa-hunt6 536
      param aa-hunt7 541
      param queue-len 30
      param aa-hunt3 570
      param aa-hunt8 511
      param queue-cme-debugs 1
      param aa-hunt4 561
      param aa-hunt1 596
      param aa-hunt5 541
     !
     service TOLL-AA flash:app-b-acd-aa-2.1.2.2.tcl
      param number-of-hunt-grps 9
      paramspace english index 0
      param dial-by-extension-option 9
      param handoff-string TOLL-AA
      paramspace english language en
      param call-retry-timer 20
      param service-name TOLL
      paramspace english location flash:/its/
      param second-greeting-time 30
      param max-time-vm-retry 1
      param max-time-call-retry 60
      param voice-mail 511
      paramspace english prefix en
      param aa-pilot 595
     !
    !
    !
    crypto pki trustpoint TP-self-signed-697467013
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-697467013
     revocation-check none
     rsakeypair TP-self-signed-697467013
    !
    !
    crypto pki certificate chain TP-self-signed-697467013
     certificate self-signed 01
      30820250 308201B9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 36393734 36373031 33301E17 0D303931 30323130 39313235
      325A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
      532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3639 37343637
      30313330 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
      D2CC0BAA 0B6AD69E 31629484 F5B648FC C7C3F079 C3A4ED00 AB8BED1A 72B88576
      011D89EB 9B4B844F 59AD21C9 064ECC48 3F7F6C56 CB96A3C4 4301CDBA 35EF8B00
      C4BF81F9 CF1940E5 913DEB00 BF9E5522 65EB9045 26FEEC56 5A0A53A3 C917E538
      32087D0A B8141401 B44E24FC 363D8BEA F6999731 139064E2 3A6B93CF 6A743ACF
      02030100 01A37A30 78300F06 03551D13 0101FF04 05300301 01FF3025 0603551D
      11041E30 1C821A4E 6173636F 6D5F4C65 6173652E 6E617363 6F6D2E63 6F6D2E73
      61301F06 03551D23 04183016 8014B1DD 36722992 86DCB004 E8300F8F F4363EBD
      C997301D 0603551D 0E041604 14B1DD36 72299286 DCB004E8 300F8FF4 363EBDC9
      97300D06 092A8648 86F70D01 01040500 03818100 3C3879B1 8A451E2F A83C1864
      D6ED617A 56E5D7ED 47058F11 B2209B51 776F237F 9E140500 B8049882 C3BB68CA
      75B82EEE FE40A2DF 942DA546 77AAB4E0 E29DD363 EC0CFE8C 3DDB6493 870C69FD
      23E6AE99 8D42FE7E BC2EB1FE A1EBFA12 BABAB04D BC69D1DB E87708A9 D2C6374B
      2B365F73 A99B28C4 C57D44AA 6917E405 4E3DCDB9
      quit
    username nascom password 0 nascom
    !
    !
    !
    !
    !
    interface Tunnel0
     ip address 172.20.0.49 255.255.255.252
     tunnel source FastEthernet0/0
     tunnel destination 172.16.16.234
    !
    interface Tunnel1
     ip address 172.20.0.57 255.255.255.252
     shutdown
     tunnel source FastEthernet0/0
     tunnel destination 212.102.4.68
    !
    interface Tunnel2
     description To Salec
     ip address 172.20.0.53 255.255.255.252
     tunnel source FastEthernet0/0
     tunnel destination 212.102.4.112
    !
    interface Tunnel3
     ip address 10.11.10.1 255.255.255.252
     shutdown
     tunnel source FastEthernet0/0
     tunnel destination 212.102.4.112
    !
    interface Tunnel10
     ip address 1.1.1.1 255.255.255.0
     tunnel source FastEthernet0/0
     tunnel destination 212.102.4.68
    !
    interface Tunnel25
     no ip address
    !
    interface Loopback10
     ip address 10.10.10.10 255.255.255.0
    !
    interface Loopback20
     ip address 20.20.20.20 255.255.255.0
    !
    interface Loopback21
     ip address 21.21.21.21 255.255.255.0
    !
    interface Loopback22
     ip address 22.22.22.22 255.255.255.0
    !
    interface Loopback23
     ip address 23.23.23.23 255.255.255.0
    !
    interface Loopback30
     ip address 30.30.30.30 255.255.255.0
    !
    interface FastEthernet0/0
     description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
     ip address 172.16.16.166 255.255.255.252
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     description $ES_LAN$
     ip address 172.16.3.225 255.255.255.0
     duplex auto
     speed auto
    !
    interface FastEthernet0/1.1
     encapsulation dot1Q 5
     ip address 192.168.2.1 255.255.255.0
    !
    interface Serial0/0/0
     no ip address
     shutdown
     clock rate 2000000
    !
    router rip
     version 2
     network 172.16.0.0
     network 172.20.0.0
     no auto-summary
    !
    ip route 0.0.0.0 0.0.0.0 172.16.3.20
    ip route 172.16.0.0 255.255.252.0 Tunnel0
    ip route 172.16.16.232 255.255.255.252 172.16.16.165
    ip route 172.16.100.0 255.255.255.0 Tunnel0
    ip route 212.102.4.112 255.255.255.255 FastEthernet0/0
    ip route 212.102.4.112 255.255.255.255 172.16.16.165
    !
    !
    ip http server
    ip http access-class 23
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip http path flash:
    !
    access-list 10 deny   any log
    !
    !
    tftp-server flash00308000500.bin
    tftp-server flash00308000500.loads
    tftp-server flash00308000500.sb2
    tftp-server flash00308000500.sbn
    tftp-server flash00405000700.bin
    tftp-server flash00405000700.sbn
    tftp-server flash00307020200.bin
    tftp-server flash00307020200.loads
    tftp-server flash00307020200.sb2
    tftp-server flash00307020200.sbn
    tftp-server flash00403020214.bin
    tftp-server SCCP11.7-2-1-0S.loads
    tftp-server flash:phone/7906-7911/SCCP11.7-2-1-0S.loads
    tftp-server flash:phone/7906-7911/apps11.1-0-0-72.sbn
    tftp-server flash:phone/7906-7911/cnu11.3-0-0-81.sbn
    tftp-server flash:phone/7906-7911/cvm11.7-2-0-66.sbn
    tftp-server flash:phone/7906-7911/dsp11.1-0-0-73.sbn
    tftp-server flash:phone/7906-7911/jar11.7-2-0-66.sbn
    tftp-server flash:phone/7906-7911/term11.default.loads
    tftp-server flash:phone/7970-7971/apps70.1-1-3-30.sbn
    tftp-server flash:phone/7970-7971/cnu70.3-1-3-30.sbn
    tftp-server flash:phone/7970-7971/dsp70.1-1-3-30.sbn
    tftp-server flash:phone/7970-7971/jar70sccp.8-0-3-32.sbn
    tftp-server flash:phone/7970-7971/SCCP70.8-0-4SR2S.loads
    tftp-server flash:phone/7970-7971/term70.default.loads
    tftp-server flash:phone/7970-7971/term71.default.loads
    !
    control-plane
    !
    !
    !
    voice-port 0/2/0
     connection plar 595
     caller-id enable
    !
    voice-port 0/2/1
     connection plar 500
    !
    voice-port 0/2/2
     connection plar 594
     caller-id alerting dsp-pre-allocate
    !
    voice-port 0/2/3
    !
    !
    !
    sccp ccm 172.16.1.225 identifier 1
    sccp ip precedence 3
    !
    dial-peer cor custom
     name SPECIAL
     name default
    !
    !
    dial-peer cor list TO-SPECIAL
     member SPECIAL
    !
    dial-peer cor list BICHAREY
     member default
    !
    !
    dial-peer voice 1 voip
     destination-pattern 1..
     session target ipv4:212.102.4.68
    !
    dial-peer voice 10 voip
     service aa
     destination-pattern 555
     session target ipv4:192.168.1.100
     incoming called-number 555
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 150 voip
     destination-pattern 590
     session target ipv4:10.10.10.10
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 151 voip
     service cme-aa150
     incoming called-number 590
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 580 voip
     destination-pattern 585
     session target ipv4:20.20.20.20
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 581 voip
     service cme-aa11
     incoming called-number 585
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 588 voip
     destination-pattern 589
     session target ipv4:30.30.30.30
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 589 voip
     service cme-aa12
     incoming called-number 589
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 3 pots
     corlist outgoing TO-SPECIAL
     description "to local numbers"
     destination-pattern [2,4]......
     port 0/2/2
    !
    dial-peer voice 100 voip
     destination-pattern 594
     session target ipv4:21.21.21.21
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 101 voip
     service cme-aaf
     incoming called-number 594
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 102 voip
     destination-pattern 595
     session target ipv4:22.22.22.22
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 103 voip
     service toll-aa
     incoming called-number 595
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 105 voip
     destination-pattern 596
     session target ipv4:23.23.23.23
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 106 voip
     service cme-aaf2
     incoming called-number 596
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 594 voip
    !
    dial-peer voice 4 pots
     description TO Tool Free Number
     destination-pattern [8-9].......
     port 0/2/2
    !
    dial-peer voice 5 pots
     corlist outgoing TO-SPECIAL
     destination-pattern .T
     port 0/2/2
     forward-digits all
    !
    !
    !
    !
    telephony-service
     load 7910 P00403020214
     load 7960-7940 P00307020200
     load 7970 SCCP70.8-0-4SR2S
     load 7911 SCCP11.7-2-1-0S.loads
     load 7912 CP7912060000SCCP050124A.sbin
     max-ephones 30
     max-dn 30
     ip source-address 192.168.2.1 port 2000
     auto assign 1 to 30
     timeouts interdigit 2
     system message NASCOM
     cnf-file location flash:
     mwi reg-e164
     max-conferences 8 gain -6
     web admin system name nascom password nascom
     dn-webedit
     time-webedit
     transfer-system full-consult
     create cnf-files version-stamp 7960 Jan 26 2010 07:10:26
    !
    !
    ephone-dn  1  dual-line
     number 581
     label SERVER
     name SERVER
     corlist incoming BICHAREY
    !
    !
    ephone-dn  2  dual-line
     number 535
     label Mohamed Fahim
     name Mohamed Fahim
     corlist incoming BICHAREY
    !
    !
    ephone-dn  3
     number 580
     label Meeting Room
     name Meeting Room
     intercom 307 barge-in
     corlist incoming BICHAREY
    !
    !
    ephone-dn  4  dual-line
     number 533
     label Mohammad Ayub
     name Mohammad Ayub
     corlist incoming BICHAREY
    !
    !
    ephone-dn  5  dual-line
     number 572
     label JOse Sawadar Reuuidan
     name Jose Sawad Reuuidan
     corlist incoming BICHAREY
    !
    !
    ephone-dn  6  dual-line
     number 564
     label Roberto Faldes
     name Roberto Faldes
     corlist incoming BICHAREY
    !
    !
    ephone-dn  7  dual-line
     number 562
     label Walid Abdus Salam
     name Walid Abdus Salam
     corlist incoming BICHAREY
    !
    !
    ephone-dn  8  dual-line
     number 107
     corlist incoming BICHAREY
    !
    !
    ephone-dn  9  dual-line
     number 570
     label Mohd. Naguaib Elbadrawy
     name Mohd. Naguaib Elbadrawy
     corlist incoming BICHAREY
    !
    !
    ephone-dn  10  dual-line
     number 542
     label Ibrahim Fathy
     name Ibrahim Fathy
     corlist incoming BICHAREY
    !
    !
    ephone-dn  11  dual-line
     number 543
     label Ahmed mohammed
     name Ahmed mohammed
     corlist incoming BICHAREY
    !
    !
    ephone-dn  12  dual-line
     number 551
     label Mohamed Rabie
     name Mohamed Rabie
     corlist incoming BICHAREY
    !
    !
    ephone-dn  13  dual-line
     number 563
     label Ahmad Sulaiman
     name Ahmad Sulaiman
     corlist incoming BICHAREY
    !
    !
    ephone-dn  14  dual-line
     number 544
     label Ayman Abdalfatiah
     name Ayman Abdalfatiah
     corlist incoming BICHAREY
    !
    !
    ephone-dn  15  dual-line
     number 500
     label Sulaiman Mohamed Annasban
     name Sulaiman Mohamed Annasban
    !
    !
    ephone-dn  16  dual-line
     number 511
     label Mohammed Muddassir
     name Mohammad Muddassir
    !
    !
    ephone-dn  17  dual-line
     number 561
     label Abbas Izhar
     name Abbas Izhar
     corlist incoming BICHAREY
    !
    !
    ephone-dn  18  dual-line
     number 540
     label Tamer Ahmed
     name Tamer Ahmed
     corlist incoming BICHAREY
    !
    !
    ephone-dn  19  dual-line
     number 541
     label NAnnanan Kuthupalakkal
     name Nannanan Kuthupalakkal
     corlist incoming BICHAREY
    !
    !
    ephone-dn  20  dual-line
     number 532
     label Ahmed Sami
     name Ahmed Sami
     corlist incoming BICHAREY
    !
    !
    ephone-dn  21  dual-line
     number 536
     label Sentha - Marai
     name Sentha - Marai
     corlist incoming BICHAREY
    !
    !
    ephone-dn  22  dual-line
     number 534
     label Anisurahman
     name Anisurahman
     corlist incoming BICHAREY
    !
    !
    ephone-dn  23  dual-line
     number 122
     corlist incoming BICHAREY
    !
    !
    ephone-dn  24
     number 307
     label intercom
     intercom 580 barge-in
    !
    !
    ephone-dn  25  dual-line
     number 124
    !
    !
    ephone-dn  26  dual-line
     number 125
    !
    !
    ephone-dn  27  dual-line
     number 126
    !
    !
    ephone-dn  28  dual-line
     number 127
    !
    !
    ephone-dn  29  dual-line
     number 128
    !
    !
    ephone-dn  30  dual-line
     number 129
    !
    !
    ephone  1
     no multicast-moh
     mac-address 001D.0956.0FAA
     type CIPC
     button  1:1
    !
    !
    !
    ephone  2
     no multicast-moh
     mac-address 0024.14B4.DC92
     type 7911
     button  1:2
    !
    !
    !
    ephone  3
     no multicast-moh
     mac-address 001C.58FB.0E56
     type 7911
     button  1:3
    !
    !
    !
    ephone  4
     no multicast-moh
     mac-address 0024.9733.B1E6
     type 7911
     button  1:4
    !
    !
    !
    ephone  5
     no multicast-moh
     mac-address 0024.9734.07AD
     type 7911
     button  1:5
    !
    !
    !
    ephone  6
     no multicast-moh
     mac-address 0024.14B4.DB3C
     type 7911
     button  1:6
    !
    !
    ephone  7
     no multicast-moh
     mac-address 0024.14B4.DD58
     type 7911
     button  1:7
    !
    !
    !
    ephone  8
     no multicast-moh
     mac-address 0024.97AA.EB2D
     speed-dial 1 100 label "server"
     speed-dial 2 101 label "dfgh"
     button  1:8
    !
    !
    !
    ephone  9
     no multicast-moh
     mac-address 0024.14B4.DCB4
     type 7911
     button  1:9
    !
    !
    !
    ephone  10
     no multicast-moh
     mac-address 0024.9734.53CD
     type 7911
     button  1:10
    !
    !
    !
    ephone  11
     no multicast-moh
     mac-address 0024.9733.8DC1
     type 7911
     button  1:11
    !
    !
    !
    ephone  12
     no multicast-moh
     mac-address 0024.9734.05B2
     type 7911
     button  1:12
    !
    !
    !
    ephone  13
     no multicast-moh
     mac-address 0024.14B4.DD6C
     speed-dial 1 511 label "Secretary"
     speed-dial 2 570 label "Mohd.Naguaib"
     speed-dial 3 540 label "Tamer"
     speed-dial 4 532 label "Ahmad"
     type 7911
     button  1:13
    !
    !
    !
    ephone  14
     no multicast-moh
     mac-address 001F.9EAE.0CC7
     type 7911
     button  1:14
    !
    !
    !
    ephone  15
     no multicast-moh
     mac-address 0017.596E.C1AC
     speed-dial 1 511 label "Secretary"
     speed-dial 2 570 label "Mohd.Naguaib"
     speed-dial 3 540 label "Tamer"
     speed-dial 4 532 label "Ahmad"
     type 7970
     button  1:15
    !
    !
    !
    ephone  16
     no multicast-moh
     mac-address 0024.14B4.DBED
     type 7911
     button  1:24
    !
    !
    !
    ephone  17
     no multicast-moh
     mac-address 0024.14B3.2490
     type 7911
     button  1:17
    !
    !
    !
    ephone  18
     no multicast-moh
     mac-address 0024.14B4.DB82
     type 7911
     button  1:18
    !
    !
    !
    ephone  19
     no multicast-moh
     mac-address 0024.14B4.9C55
     type 7911
     button  1:19
    !
    !
    !
    ephone  20
     no multicast-moh
     mac-address 0024.14B4.DC8B
     type 7911
     button  1:20
    !
    !
    !
    ephone  21
     no multicast-moh
     mac-address 0024.9733.B6BB
     type 7911
     button  1:21
    !
    !
    !
    ephone  22
     no multicast-moh
     mac-address 0024.14B4.DD04
     type 7911
     button  1:22
    !
    !
    !
    ephone  23
     no multicast-moh
     mac-address 0017.593A.318E
     type 7940
     button  1:9
    !
    !
    !
    ephone  24
     no multicast-moh
     mac-address 001D.A266.DC16
     speed-dial 1 500 label "BOSS"
     type 7960
     button  1:16 3:24
    !
    !
    !
    ephone  25
     no multicast-moh
     mac-address 0017.5A7B.89FC
     type 7905
     button  1:23
    !
    !
    !
    ephone  26
     no multicast-moh
    !
    !
    !
    ephone  27
     no multicast-moh
    !
    !
    !
    ephone  28
     no multicast-moh
    !
    !
    !
    ephone  29
     no multicast-moh
    !
    !
    !
    ephone  30
     no multicast-moh
    !
    !
    banner exec ^C
    % Password expiration warning.
    -----------------------------------------------------------------------
     
    Cisco Router and Security Device Manager (SDM) is installed on this device an
    it provides the default username "cisco" for  one-time use. If you have alrea
    used the username "cisco" to login to the router and your IOS image supports
     
    "one-time" user option, then this username has already expired. You will not
    able to login to the router with this username after you exit this session.
     
    It is strongly suggested that you create a new username with a privilege leve
    of 15 using the following command.
     
    username <myuser> privilege 15 secret 0 <mypassword>
     
    Replace <myuser> and <mypassword> with the username and password you want to
    use.
     
    -----------------------------------------------------------------------
    ^C
    banner login ^C
    -----------------------------------------------------------------------
    Cisco Router and Security Device Manager (SDM) is installed on this device.
    This feature requires the one-time use of the username "cisco"
    with the password "cisco". The default username and password have a privilege
    vel of 15.
     
    Please change these publicly known initial credentials using SDM or the IOS C
     
    Here are the Cisco IOS commands.
     
    username <myuser>  privilege 15 secret 0 <mypassword>
    no username cisco
     
    Replace <myuser> and <mypassword> with the username and password you want to
    .
     
    For more information about SDM please follow the instructions in the QUICK ST
     
    GUIDE for your router or go to http://www.cisco.com/go/sdm
    -----------------------------------------------------------------------
    ^C
    !
    line con 0
     password 7 0518071A25451A58
     login
    line aux 0
    line vty 0 4
     privilege level 15
     password 7 0017121300525F57
     login local
     transport input telnet ssh
    line vty 5 15
     privilege level 15
     login local
     transport input telnet ssh
    !
    scheduler allocate 20000 1000
    !
    end

    Subject: RE: Tcl script is working but the call didt route the hunt group
    Replied by: Anusha Kannappan on 01-03-2010 06:54:34 AM
    Hi Javeen,
     
    Please clarify few of my queries related to call scenario in order to investigate the issue in depth.
     
    You have mentioned when the caller dials the company number the greeting message is played. Here does the number means the pilot number? If not what is the number?
    service cme-aaf flash:app-b-acd-aa-2.1.2.2.tcl
    param aa-pilot 594
     
    And with respect to the dial-by-extension, here also first the pilot number has to be dialed where we get the menu options being played and there we need to select the dial-by-extension option to call the destination with an extension. Please let us know whether the above mentioned procedure was carried out? If not how is being done and please share the call flow with the previous working conditions.
     
    Also share us your logs with the following debugs enabled
     
    debug voip application tcl
    debug voip application state
    debug voip application script
     
    Thanks,
    Anusha

    Subject: RE: Tcl script is working but the call didt route the hunt group
    Replied by: javeen shanavas on 01-03-2010 02:24:12 PM
    thnks 4 ur quick responce......
     
     
    here we jst dail the company number 912688882,which mathes the (dial peer voice 3 pots) port 0/2/0......thre we confgre plar to 594.......thn it mathes the cme-aaf script .which is  working in  assocition wth the acdf......thrz a hunt to the extention ,which is not workng.........

    Subject: RE: Tcl script is working but the call didt route the hunt group
    Replied by: javeen shanavas on 01-03-2010 02:28:03 PM
    srry port 0/2/2

    Subject: RE: Tcl script is working but the call didt route the hunt group
    Replied by: Yawming Chen on 01-03-2010 06:17:59 PM
    If it was working fine but suddenly stop working then I will check if there is any thing changed recently, like IOS configuration.
    So problem could be
    1. IOS config
    2. For some reason, Tcl application did not collect digits correctly
    3. Script error
     
    If you are using standrad BACD script then you can open a TAC SR. If you are using costom script then you open  a SR against Cisco Developer Support if needed.
    http://developer.cisco.com/web/devservices
     
    But for your case I can see you are using a very old version of BACD script. There is known issue of using the version prior 2.1.2.3 with the later vesrion of IOS image. So before digging your issue I suggest you download latest version of BACD script
     
    http://www.cisco.com/cgi-bin/Software/Tablebuild/doftp.pl?ftpfile=/cisco/voice/ip-phone/ip-iostsp/cme-bacd-3.0.0.2.tar
     
     
    Thanks,
     
    Yawming

    Subject: RE: Tcl script is working but the call didt route the hunt group
    Replied by: javeen shanavas on 02-03-2010 06:49:15 AM
    thnks 4 ur responce
     
     
    no.......i didt any changes in config side.i think the following script is nt working.......

    service queue flash:/bacdprompts/app-b-acd-2.1.0.0.tcl
     !
     service acdf flash:app-b-acd-2.1.2.2.tcl
      param aa-hunt2 511
      param number-of-hunt-grps 8
      param aa-hunt6 536
      param aa-hunt7 541
      param queue-len 30
      param aa-hunt3 570
      param aa-hunt8 511
      param queue-cme-debugs 1
      param aa-hunt4 561
      param aa-hunt1 596
      param aa-hunt5 541

     
    hve any option?????????/

    Subject: RE: Tcl script is working but the call didt route the hunt group
    Replied by: Vijay Prasad Neelamegam on 02-03-2010 07:18:52 AM
    Hi Javeen,

    I went through your config,Here Dial-by-extension option is 9,what is the desired extension number you are trying.Is the e-phone is avaliable for that number?


    As Yawming said,can you try this with latest script from the following location and provide us the traces with these debugs enabled.


    http://www.cisco.com/cgi-bin/Software/Tablebuild/doftp.pl?ftpfile=/cisco/voice/ip-phone/ip-iostsp/cme-bacd-3.0.0.2.tar

    debug voip application tcl
    debug voip application state
    debug voip application script
    debug voip application core


    Thanks

    Vijay