User Device Profile

Version 1
    This document was generated from CDN thread

    Created by: Gavin White on 25-11-2009 07:35:54 AM
    I seem to be having an issue creating a Device Profile.
    Using UCM v7.1
    When I try to create a device with a call to addPhone I get the following fault:
    "The specified name has invalid characters or is not formatted correctly for this device type."
     
    This occurs with any combination of name eg: "SEP0000000000", "1", "aaa"
     
    Does anybody else experience this and know a way to create Device Profiles??

    Subject: RE: User Device Profile
    Replied by: Dan-Anders Hook on 29-11-2009 10:25:05 PM
    Hi,
     
    Are you creating a device or a device profile? Your question is a bit contradictive. Can you post your xml?
     
    Kind regards,
     
    //Dan

    Subject: RE: User Device Profile
    Replied by: Gavin White on 21-12-2009 02:09:02 AM
    Hi Dan, I may be wrong but it is essentially the same thing but with class == Device Profile;
     
    The action called is "addPhone" and the main device fields I am using are as follows:
    <name>aaaa</name>
    <description></description>
    <product>Cisco 7940</product>
    <model>Cisco 7940</model>
    <class>Device Profile</class>
    <protocol>SCCP</protocol>
    <securityProfileName>Cisco 7940 - Standard SCCP Non-Secure Profile</securityProfileName>
    with this I get a result of:
    <faultstring>The specified name has invalid characters or is not formatted correctly for this device type.</faultstring>
    If I manually create a Device Profile called "aaaa" I can pull its configuration by doing a getPhone wiith <phoneName>aaaa</phoneName> and all looks fine, so I'm sure I am close to the answer..

    Subject: RE: User Device Profile
    Replied by: Dan-Anders Hook on 31-01-2010 04:01:10 PM
    Hi,
     
    Sorry for the late respose. My question was based on the fact that there are both an "AddPhone" as well as an "AddDeviceProfile" action. I have'nt look at it in depth so I don't know if it is possible to use AddPhone to create a device profile. Since there are two separate methods my guess is that there is something more that differs than the class.
     
    Kind regards,
     
    //Dan

    Subject: RE: User Device Profile
    Replied by: dan turner on 01-02-2010 03:38:30 PM
    ...., 
     
    Dont know if im being silly here but when i add phone through CCMADMIN on CCM (4.1.3) i dont enter a device name...
     
    i put in the mac and a description and it appears to prefix the MAC with SEP to create the device name automatically
     
     

    Subject: RE: User Device Profile
    Replied by: Gavin White on 15-02-2010 01:12:36 PM
    Dan - Thanks for pointing that out - I had incorrectly assumed it to be for Default Device Profiles.. 
    Looks like that should do the trick.